Green becomes black

Good evening Forum,
How in peace is it possible that a green screen suddenly becomes black after I export a piece of film?

Comments

  • @AppievanZon ; Are you exporting the clip so that the area where the green screen would be transparent?  If so, I think the only video format that supports transparency is the Cineform +Alpha and, of course, the Uncompressed AVI but those will be monster sized files.  But unless you put something behind them when you view them that area will appear black even though there's transparency there most of the time.  Now, if you have dropped a background into your clip to fill the areas that had green screen and it's rendering out black that is a new one on me and I have no suggestions as to the cause.

  • Good evening tddavis,
    Yes! You're all right. I make an intro of 7 seconds. And I thought I'll keep it for another time. But the clip was black and not transparent.

  • Aladdin4dAladdin4d Moderator

    @AppievanZon @tddavis has the right answer. You need to make sure alpha is selected and choose a format that supports transparency for export. On Windows that means using Cineform or uncompressed AVI or an image sequence using PNG or OpenEXR. On Mac the image sequence options are the same but instead of Cineform or uncompressed AVI you would choose ProRes

  • @AppienvanZon ; Since your clip is only 7 seconds, I would choose the PNG (be sure to get the one that says +alpha) sequence option @Aladdin4d mentioned above.  It is lossless and much easier (for me, at least) to deal with than transparent video formats.  Just create a Folder and export the project  into it and then when you want to reuse it choose the "import sequence" method.  It's my preferred format on short clips of 15 secs or less. If you export at 24 frames per second, that's less than 200 frames, if my head did the math right. 

  • tddavis, Sorry, that's impossible. Because the clip also has sound.

     

  • @AppievanZon ; That does present a wrinkle but it is still doable.  Export the video as PNGs then export only the audio to a separate file.  As long as you use the same frame rates on both exports it should be in sync when the PNGs are imported as a sequence later and the audio file can be placed with the sequence then.  It's a bit more work to be sure, though.  I have never messed with the Cineform plus alpha settings but I did try the AVI with alpha once and the export was prohibitively huge for me.  Might not be bad only 7 secs though.

Sign in to comment

Leave a Comment