Exporting in Hitfilm Express 2017

After downloading and activating Hitfilm Express 2017 I'm unable to use any of the pre-sets for exporting. All of the pre-sets are showing a locked padlock and although the program goes through the motions of exporting a project in MP4 format, the saved project shows only a black screen when played back. The only export function which seems to work is to save as AVI format. Any help to resolve this would be very much appreciated.

Comments

  • I've spent around two hours creating a video piece in HITFILM Express 2017 and now I can't export it! Why?....Not a happy bunny!

  • Triem23Triem23 Moderator

    Prasma, the lock icon merely means you can't delete or edit them. They should work. If mp4 isn't working, but AVI is, then try updating your GPU drivers and reinstalling Hitfilm. 

    @CraigDee if you mean the Export Queue hasn't activated, click the Menu on this page, select Account, then scroll down and check "View Activations." Make certain your software is activated. 

  • Thank you, Triem23. Reinstall seems to have solved the issue.  

  • edited May 26

    @Triem23

    Hitfilm Express 2017 is my first editor and have only had it as of May 25th, downloaded it free. Of the work I've already done, it seems as though I can't export it properly. I get an MP4 file with only audio and no visuals.

    I receive the following messages no matter the preset I choose:

    GL_INVALID_OPERATION - The specified operation is not allowed in the current state.

    The offending command is ignored and has no other side effect than to set the error flag.

     

     

  • Triem23Triem23 Moderator

    @Ffnetnut try making certain your GPU drivers are updated. You might have to contact support.

  • @Ffnetnut This is an issue we are working on at the moment. The render process (named HitFilmRenderClient.exe) is trying to use your integrated GPU instead of using your dedicated one.

    In the meantime, you can work around this by going to your NVidia or AMD settings and forcing the render client to use the dedicated GPU.

    Sorry about the inconvenience.

    (picture for reference only)

  • edited May 26

    @CedricBonnier

    Thank you for explaining the issue with rendering, however, could you provide instructions on where to find and how to change the "NVidia" or "AMD" settings so I can share my work?

    I've never heard of either of the above programs(?)

  • @Ffnetnut These are the settings for your graphics card drivers. I assumed that you had a dedicated GPU but I might have spoken too hastily, do you know what graphics card you have? Could you give us more details about your machine please?

  • Triem23Triem23 Moderator

    @Ffnetnut if you don't know how to check your system specs, there's a section on how to do that 17 minutes into this tutorial. 

    https://youtu.be/Yqhl0mRuTng

  • edited May 26

    @CedricBonnier

    Windows 8.1 ; 64-bit system  ; 4 GB RAM (3.89 GB usable)

    Processor: Intel(R) Core(TM) i7-3537U CPU @ 2.00GHz   2.50GHz

    Display adapters: Intel (R) HD Graphics 4000 and NVIDIA GeForce GT 720M

  • edited June 6

    I have the exact same problem as ffnetnut...what should I do?...the software is great but the export problem is messing everything up.Someone please help me.

  • Aladdin4dAladdin4d Moderator

    @Ffnetnut You need to use the Nvidia control panel to force HitFilmRenderClient.exe to use your 720m GPU instead of the HD 4000. To do that right click on your Desktop and select Nvidia Control Panel

    Once it opens look under 3D settings on the left hand side and select Manage 3D Settings.

    Go to the Program Settings tab. There will be a drop down list of programs under Select a Program to Customize: but the one you need to customize, HitFilmRenderClient.exe won't be in it so you'll have to click Add and browse to where you have HitFilm installed to find HitFilmRenderClient.exe and add it to the list. Once it's added, select it.

    Now you can select the preferred GPU under Select the preferred graphics processor for this program. Select the Nvidia entry and you should be good to go.

  • somebody can help me and explain how to do it for ATI mobiity Radeon HD5000?

    In Hitfilm Express 4    I export(render) everything but in Hitfilm Express 2017 (the same notebook) I can not  :-(

    When I try to render, start exporting after few seconds I have messagge:

    "PROCESS FINISHED UNEXPECTEDLY"

     

    thanks

     

     

     

  • Hey guys how do I change the default storage/export path .

  • @Kaviyarasu  just click on the "OUTPUT" in the QUEUE and it will remember it.

  • i made video taking  5 hr.. but during export it shows... 

    "GL_INVALID_ OPERATION-the specified operation is not allowed in the curret sate" 

    In second paragraph it also has been written -the offending command is ignored and has no other side effect than to set the error flag.

    i feel really frustrating  what i suppose to do????

    hitfilm I coundnot get wht is meaning can u help me HITFILM...

  • What are your system specs?  OS, CPU, graphics card, RAM, and hard drive.

  • Someone help me with the Exporting. I have many different Tracks, but want them as 1 Video. I cant figure out how to do that. I need help quick!

  • What steps are you taking to try to export, and what is happening when you take those steps?

Sign in to comment

Leave a Comment