HitFilm Plugins

Install Update

Compatibility

Available for Windows and Mac OS X. 64-bit operating systems only. Requires one of Premiere Pro, After Effects CC, Final Cut Pro X, Vegas Pro 12/13, Motion or DaVinci Resolve 11.

Minimum system requirements

Learn to use HitFilm

Most helpful articles

All questions


Can't find an answer? Ask our team »

View your questions