Timeline in Hitfilm 4 Express is very laggy and freezes often.

yet another problem again. the reason i took a break from uploading on my youtube channel was because of all of these problems, so don't be surprised if i run into another problem and post another thread.

an example of what is happening is here:  https://www.youtube.com/watch?v=-BfMuhhAKrs&feature=youtu.be

so, when i preview my edits and my video in the timeline, it's just extremely laggy, and it freezes every so often. nothing more i can explain.

my computer should be able to handle hitfilm 4 express. the issue seems to keep getting worse, as i never ran into the laggy timeline problem i have now when i first downloaded and edited in express.

do i not have enough ram allocated to hitfilm? is that how it works? i have plenty of space in my hard drive.

my specs and parts are here: 

Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
8.00 GB of RAM
64-based OS, x64-based processor

Windows 10

Corsair Carbide SPEC-02
MSI B150 PC Mate
Intel i5 6500
Gigabyte GTX 1060 Windforce
EVGA 600 BQ
Crucial Ballistix Sport LT DDR4 RAM
WD Blue 1TB HDD

i also have an OCZ Trion 150 120GB SSD not plugged into my pc.

removing the audio sometimes reduces the lag, and eventually ends up fixing it completely at the end (see in the video) ,but it's not really noticeable. plus, who wants to edit and export their video without any audio?

this laggy timeline seems to happen in every editing software i use. 

 

Comments

  • edited August 23

    https://drive.google.com/file/d/0B01ci7dc2fYVUS03Q0hHXzI1NFk/view?usp=sharing

    @Hapun  This is a recycled photo so ignore the arrow pointing to the word OPTIONS.  But next it is the word FULL that's what you need to change.  This is your preview settings.  If you set it at half or better yet 1/4 the lagginess will ease up.  Now, the picture loses some clarity but this only on your screen.  The export will be full output but it will let preview the clip in realtime for the most part unless you have a lot of intensive effects.

    I am not familiar with your layout but this is the default layout so hopefully you know where this toolbar went to.

     

  • edited August 23

    thank you for the reply. tried what you suggested.

    the problems are still occuring. there is little to no change on the performance and everything is still exactly like it was shown in the video.

    very very confused.

  • Aladdin4dAladdin4d Moderator

    Sounds like your screen cap software is making files with a high decode overhead which makes them difficult to edit. Check this thread on how to transcode for better editing performance.

    https://hitfilm.com/forum/discussion/42415/transcoding-to-fast-decode-avc-for-timeline-edit-performance

    If you're using OBS @NormanPCN has some tips on setting it up to produce files that are easier to edit in that thread as well.

    For really detailed info check out @Triem23's HitFilm University

    https://www.youtube.com/watch?v=Yqhl0mRuTng

  • edited August 23

    I get this exact same issue, especially if I am using 3D Extrude.  But when I turn off 3D Extrude it seems to be better, then I just add 3D Extrude effect when I am about to render.  Do an elimination process to locate the exact effect or whatever else is causing the lag.

  • i use OBS Studio. does norman have a forum thread explaining how to produce better files in it? can't find one.

    i really don't want to use any other applications to help me with my files unless it's absolutely needed. i work too hard as it is to edit and it'd be a pain to do things with handbrake and stuff like that, so if i get OBS Studio configured so it doesn't almost break Express, that'd be great.

  • @Hapun "i use OBS Studio. does norman have a forum thread explaining how to produce better files in it? can't find one."

    Look two posts above your post. The link was given there. For redundancy I include it again. The posts regarding OBS are near the end of that thread.

    https://hitfilm.com/forum/discussion/42415/transcoding-to-fast-decode-avc-for-timeline-edit-performance

  • Aladdin4dAladdin4d Moderator

    @Hapun NormanPCN doesn't have a separate thread for OBS but he has comments with specific settings for OBS in the thread I linked to. The fifth comment in the thread covers the x264 settings and the sixth comment covers the NVENC settings.

  • edited August 24

     @NormanPCN apologies for my ignorance, didn't pay attention to the actual poster or read the comments, only the thread.

    @Aladdin4d i'll experiment with the settings and i'll bring back the results.

  • i've read and put all of your suggestions together and i definitely see that my files are much easier to edit. simple transitions as additive dissolve don't lag and don't take 5 seconds to complete when they're 1 second long anymore. i can finally edit videos without taking hours.

    however i only experimented with one clip, so the problem could come back if i edit larger video clips. we'll see though. for now, everything is much better.

  • Glad to hear your situation has big improvement using the OBS fast decode settings. Larger media files should not be any slower to edit.

Sign in to comment

Leave a Comment