Render EXR sequence with transparent part

Generated a EXR sequence from Houdini, that by default leave with transparency the parts with no objects. HF3P consider this as images with variable size and didn't render it after few frames. Any way to make it consider fixes size images with just a transparent part.

Comments

  • HitFilm only supports image sequences with constant image size, there is no workaround unfortunately. Maybe you can force the image size in Houdini?

  • In fact the image is always rendered with the same size, just does have a transparent part with variable size.

  • Hmmm, there might be an issue with our OpenEXR reading. Could you send us some of your images? At least the first frame and the problematic frame (first frame that doesn't play).

  • Sent using the support form

  • edited July 2017

    About the image size, checked using Affinity Photo and MediaInfo and they are all set as 1280x720. InfranView for some reason didn't count the upper transparent part.

    Transforming all the images into 1280x720 png the video sequence disappear at 1:11 in HFP at 25 FPS. Can download here the files.

    Rendering the EXR as video using another tool produce the whole sequence but with a much darker result.

  • edited July 2017

    @davide445 I just had a look at your sequence and the reason why it stops working is because frames "Disintegrate geometry.mantra1.0037.png" and after do not contain an alpha channel whereas all the frames before do. HitFilm does not support any variation in format between the frames of a sequence.

    One way to work around it would be to split your sequence into two: one for frames 1 to 36 and the other one for frames 37 and up. Or you could add a transparency channel for all images and it will work.

    We should probably improve this... one for the wishlist!

  • @CedricBonnier I think I need to check Houdini rendering settings, since appear there are some odd behavior in just this and another couple of frames.

    Thanks!

  • If think it's just that because the frame hasn't got any transparent or semi transparent pixels, it probably "optimises" the image to remove the unnecessary alpha channel.

    HitFilm however isn't very tolerant, it just refuses to play any frame of a different format than the first frame. Maybe you could force houdini to save every image with an alpha channel?

Sign in to comment