I got a new PC, but HitFilm is still stuttery when applying FX.

I have a new PC - ASUS M32, with 16gb DDR4 memory, 1tb hard drive, i5-6400 CPU @ 2.7ghz., GPU is a PCIE XFX-ATI Radeon HD 5450 2gb. board with VGA, HDMI, and DVI, dual monitor capability. I am using the VGA connection to my 27" Specter 1080p monitor @ 1920x1080, also a new monitor.

And yet, when I am moving a Light Sword around, it does not move at first, then jumps into the spot where I released the mouse button. It is a bit frustrating, but it has worked. So far, I have not tried any other effects. I bought this PC because of the demands of HitFilm and it is all I can afford right now. Is there a way to get HitFilm to work better?

Comments

  • edited May 7

    Out of interest, what made you choose the Radeon HD 5450? Sorry, but it seems to be a piece of very cheap no frills card?

    My video card costs 5 times more than yours and I will want to upgrade it soon.

  • @DataDesign   I'm not sure if you have already checked this or not but it sounds like you might be previewing at full or antialiased settings in the viewer window.  Check that button up at the top of the viewer window next to OPTIONS. When you click on it you have 4 settings; if it's not already on 1/4 or 1/2 give them a try and see it helps with the jerkiness.  There might still be some even on 1/4 but hopefully it will make things more manageable.  Have you tried rendering out anything of the lightsaber and does it move smoothly in the export?

  • @Yeremyah "Out of interest, what made you choose the Radeon HD 5450? Sorry, but it seems to be a piece of very cheap no frills card?
    My video card costs 5 times more than yours and I will want to upgrade it soon."

    Card was on sale and had 2gb. Can not justify hundreds on a GPU at this time. Seems to meet specs on HitFilm site.

  • Triem23Triem23 Moderator

    Tddavis has the performance tips. Unfortunately your "new" computer has a 10-year-old GPU that has significantly worse performance than the intel HD 4000 considered minimum spec. 

    I have never said this before, but you would literally be better off removing the GPU from your computer and using the integrated GPU on your i5. 

    No joke. Here's the benchmark comparison. 

    http://gpu.userbenchmark.com/Compare/Intel-HD-530-Desktop-Skylake-vs-AMD-Radeon-HD-5450/m33102vsm7719

  • @tddavis I found that it was set to FULL, so I tried it at 1/4 and it was a lot more responsive. The only thing is that it is pretty blurry. But it seems better now. Many thanks. Still looks like I have some hours ahead of me for the roto.

  • Triem23Triem23 Moderator

    I still recommend removing your GPU. No fooling. If you looked at the posted benchmarks, the HD 530 built into your CPU is about 5 times faster than that Radeon 5450. Sorry, but that Radeon would function better as a paperweight. 

  •  Ok @DataDesign that is your choice if you cannot justify getting a better video card.  But think about it, you rather suffer with slow performance, so isn't justification found in that alone?

    Having a "no frills" video card like that old cheap thing will hold you back today, tomorrow and beyond. Up to you though.

    All the best.
     

  • edited May 7

    Hell, I've been using the GTX980 for years and it'll sometimes get bogged if to many comps are going... Broke down today and ordered the PNY GTX1080 PNYGTX1080XLR8  on sale at Amazon for $549. Yea, it's pricey but what the hell.. Add around 15-20% O.C. and it'll perform like the TI version.

    You can always go with a GTX1070 for cheaper (seen them for $379 and up). Either way (AMD or NVIDIA) the guys are right, the GPU you listed isn't really cut out for HF based on req. spec (listed or real world). Then again,  use the opportunity (while waiting to upgrade GPU) to rethink how you create  scenes. Optimize you're work flow.

    Example: Creating the same effect with fewer layers/comps, simplify any particular VFX taxation on hardware resources while obtaining intended result.... VFX can be done 1001 different ways, the key is to discover the most efficient solution (regardless of hardware).

  • @DataDesign  Put this in the "something to think about" category:  instead of trying to render out an entire video at once, break it up into just the effect shots one at a time (so instead of a 3 minute video a 15 sec composite with particles and whatnot) and render that out as lossless uncompressed AVI (it will be huge in size) with sound intact, or a PNG sequence (no sound) but lossless still and you can export just the sound for when you import it as a sequence later.  After you have all the effects sequences rendered then you can put it together in the editor and render it out as 1 video.  It might not save any time, but it might make your system's performance better in the long run, and get you through until such time as you can seek alternative GPU solutions.

  • @triem23 Wow! Seems like I made a wrong turn and went back in time. Video card was purchased last year, so I guess I know why is was on sale so cheap. I will try the built in GPU again, but if I remember right, (and I am not saying I do) when I first tried HF 2017, I simply put the Light Sword effect on the layer and HF aborted without an error message. Then after I put in 'new' board it at least worked, however slowly. I am amazed that the test page you showed gives it over 300% better performance with the integrated GPU.

    Thanks

  • @tddavis, @yeremyah, @sarasota

    Thanks for all the feedback and advice guys. I really appreciate it.

  • your amd videocard xx50 are for office, cheap enough for office-word, surfin and play flashgames. cheap means not only "not expensive", it means cheap on power too.

  • I removed the video card. Then when I tried to run HF 2017, I got the message "There is a problem and Hitfilm needs to close". It asked if I wanted to send a dump to FXHOME and I did send it. I then tried the latest install and it asked if I wanted to REPAIR HF and I clicked OK. Then when I restarted HF, it seemed to work ok. I have not given it a real try by adding a bunch of effects yet, but the comp I was working on has a bunch of key frames and it seems to work without crashing. I will get back to it later.

    Thanks again to all who replied.

  • @DataDesign, you might make sure your video driver is up to date

Sign in to comment

Leave a Comment