How to soften (blur) unrolled 3D models?

Maybe this is a stupid question but I am a little stuck: I would like to slightly blur some 3D models to match the video footage. I am using "3D unrolled" because there are multiple models, shadow catcher planes and 3D particle effects - turning them into 3D planes messes everything up. Unrolled 3D models cannot have effects and a grading planes grade everything below it including the video. Embedded composite shots do not works as soon as I have a shadow catcher plane that has to be multiplied with the video.

Any help is appreciated.

Comments

  • Triem23Triem23 Moderator

    Pro 4 or pro 2017?

    In Pro 4 there is absolutely no way around this* as 3D unrolled models just can't have effects applied. This is because effects are applied after a base layer is rendered, but 3D unrolled layers aren't rendered until a 2D layer or top of stack is reached. 

    *Although you can place all your models into a single layer... 

    In Pro 2017 the new depth layer function can allow you to leave a model or particle layer in 2d mode but select another layer that will correctly occlude it. So, if you put all models into one layer (they can still rig to points) and set the Depth layer to the particles (multiple particle sims can also go to a single layer) then you can add a blur and still have occlusion. 

  • Thank you! I have Pro 2017 and I'll try to understand the depth layer concept asap ;-)

  • Triem23Triem23 Moderator
    edited April 2017

    No one's really done a full tutorial yet, but here's a super quick breakdown using one model and one particle sim so you can at least see where the controls are. 

    https://youtu.be/w-7n8nGO5j4

    You'll see a 2D particle layer above a 2D model layer. By setting up the Depth layer the model appears in front of the particles (as it is in its 3D coordinates). Then adding effects. 

Sign in to comment