Merge Audio/video problems

This seems to be a side effect of the workflow for merging audio and video, combined with the fact that HitFilm doesn't span clips correctly.

First off, since Red cameras span ProRes as well as Raw into 4GB segments, long clips are divided into sequences of clips. They're all in a single folder, and the FOLDER should be interpreted as a clip (complete with an included LUT), but they're not so I end up with a bunch of clips for a single take. This spanning thing isn't specific to Red; I've had other cameras do it also like the GH3. The RMD folder + LUT is new to the latest Red bodies though. It's part of the in-camera color grading workflow.

So... I can put them all in the timeline. But merging only works on the first one, and it's broken: the audio is trimmed to the length of the video, and I can't extend it... but merging the 2nd clip SHOULD work, it's the same take, just the next part of it.

Maybe there's a way to combine multiple clips into one, which would be a clumsy workaround for not having a way (that I know of) to import a sequence of clips as a single clip.

Comments

  • HendoHendo Staff

    Yeah, as you noted, the Merge Audio/Video feature wasn't designed to handle that workflow. A couple of workarounds:

    1. You could combine the video clips on a timeline and export to a new video file. Then bring that video back in for the merge. Not ideal, I realise, but if it was just a one-time requirement then this might be acceptable.

    2. You could cut up your audio in an editor like Audacity to roughly find the equivalent sections for those video clips. Then you'll be able to merge the clips individually.

  • 1 isn't a great option, since I run into this quite a bit, though if you guys can add clip spanning, then it would probably have the side effect of mostly curing this issue, in addition to making the workflow better.

    Does the merge feature require that the audio and video line up near the beginning of the audio clip? I'd been hoping that I'd be able to just merge one video clip at a time to the corresponding audio clip, then just drop the merged clips into the timeline... but only the first video clip in the sequence synced.

  • Well, it turns out that Red is curing the ProRes problem...  so there won't be a need for spanned ProRes reassembly any more.

    So that should simplify that part. Now all we need is RedCode support... :)

  • edited April 17

    I really hate to be bearer of bad news (or troubleshoot notes) but the matching issue is quite prevalent on far more mainstream mediums, it seems.

    I'm actually using a 6D for an interview while the audio's coming from a Zoom H6.

    While I'd like to note that the audio file is approximately twice the length of the video file, I fail to see how this is an issue. You're essentially coding a software to apply as per reference, and since this actually takes place in the Media Bin, as opposed to the timeline where you'd think a mix-up is possible. . . This shouldn't happen.

    I was a long time user of a Plugin called PluralEyes, a software dedicated for this function. Even while situating the reference and main audio on a time line packed with other files, this simply never happened.

    I really hope this gets patched. Was really psyched over this feature when I learned it came with the Hitfilm Pro suite.

  • edited August 20

    I return to this thread to ask if there's been any serious revision of the Merge Audio feature.

    I'm looking at some GH4 footage and recording from a lavalier. They're in the media bin. I highlight both and ask the software to merge.

    The result is a mess. 

    Yes. My Hitfilm is upto date. 

Sign in to comment

Leave a Comment