Need some help here with freeze scene

First of all, sry for my english.

Now, here its my problem: I want to freeze a frame for a certain time (3 seconds) and insert a picture frame while it is frozen. However, when I create a composite shot of this frame, it is black. Follow the exemplifying images:

Without composite shot: https://s14.postimg.io/ko47d8olt/sem_composite.png

With composite shot:https://s10.postimg.io/yah9v4c21/com_composite.png

 

What can i do to solve this problem? 

Comments

  • CNKCNK
    edited August 2016

    Export the frame after you've selected the moment you want to freeze in the timecode like so:

    Now import the frame and place it in the timeline. Increase or decrease the duration like you normally would.

    If you wish to place a picture frame on top, you want to place it above the exported frame in the timeline.

  • Thx dude, i'll try :D

  • Triem23Triem23 Moderator

    Kevin's given you the easiest way to do it. Hitfilm has a "Speed" effect, but, honestly it's enough of a pain, I would just export a still and cut it back in. 

  • Export and import will get the 'popping' of the AA we all know and love. ;)

    Setting Speed to 0 instead works fine and doesn't come with the usual "What is it doing?" problems.

  • I have a video on creating freezeframes although most has already been said.

    https://www.youtube.com/watch?v=15S4XGKHz6Y

  • Thx everyone :D problem solved

  • @Palacono: I used the frame export/import technique numerous times on a recent software demo video and never saw the popping you mention.  What exactly is the problem?  (If you need to point me to a different thread, feel free.  My activity here is sporadic at best, so I haven't been keeping up with recent discussions.)

  • edited August 2016

    @jsbarrett it depends on the scene and the amount of detail in it, but when you export a .PNG, Hitfilm will apply Anti Aliasing to it. It will apply more if you actually have AA turned on in the viewer and slightly less if you have it turned off (i.e. FULL view).

    The result is that when you reimport it and put it in your scene, it will look a little softer than the footage either side of it. This will carry over to the final export, as everything will get more AA applied to it, so that frame will have got it twice. If you haven't noticed it so far, then don't worry, but if you do notice it, then here's an alternative method:

    Duplicate your video clip. Right Click>Options>Mute the second copy in case it has audio, or you'll be doubling that up. Rename it to Freeze Frame, if you like. :)
    Cut the video at the freeze frame you want. Discard the section before it. Apply the Speed Effect to the clip and set the speed to 0.

    You now have a single frame frozen until the end of that clip. Do with it what you would do with the single frame you were importing before.

  • @Palacono: Great explanation of both the problem and solution.  Thanks!

  • @Palacono ; Good call there! 

  • So basically the export frame function is broken?

  • @KevinTheFilmmaker - its not broken, it is functioning exactly as designed. It could, perhaps, be improved in future development to be even more versatile.

  • edited August 2016

    @KevinTheFilmmaker Not so much broken, as using the same function to export a single frame as the final render export-as-frames option uses, with no way to turn AA off in that, despite it not being turned on in the viewer.

    So...functioning sub-optimally? :)

    Ah, @AxelWilkinson just beat me to it. So, now I ask: " Is applying AA when it's not asked for, and is specifically turned off in the viewer, 'as designed'? Why would you intentionally do that? It's an oversight at best."

  • I see. Thanks for clarfiying!

  • I created a composite shot and used the Speed plugin and worked/works fine atm. 

    About export a frame, i already used other editors and on it seems like a pixel picture and its clearly visible the pixels on the image. But if Hitfilm will apply anti aliasing to it, its good for me, i will try another time. And sry my english, it sucks :P im learning atm that too :D

Sign in to comment