HitFilm Perfomance

I just bought HitFilm....and although it is really awesome, it also is very sluggish and laggy. Especially when I start adding particle effects. But it won't even play back a preview of a normal movie or image sequence by itself. The preview feature is essentially useless...which really, really sucks. For a $400 software, I'm surprised. It can't be my graphics card either....I've run a lot of other graphics intensive programs (blender, 3ds max, maya, graphics intensive video games...)... My GPU is an Radeon HD 5650 1 GB. If i'm correct, that should be more than enough to run HitFilm...My CPU is good too. It's an AMD Phenom II N930 Quad Core 2.00 Ghz. Can someone please tell me how to get hitfilm to stop being so slow??
Thanks in advance

Comments

  • Have you made sure to download and install the latest version of Quicktime?
    Reboot yout pc and try again.

  • I just bought HitFilm....and although it is really awesome, it also is very sluggish and laggy. Especially when I start adding particle effects. But it won't even play back a preview of a normal movie or image sequence by itself. The preview feature is essentially useless...which really, really sucks. For a $400 software, I'm surprised. It can't be my graphics card either....I've run a lot of other graphics intensive programs (blender, 3ds max, maya, graphics intensive video games...)... My GPU is an Radeon HD 5650 1 GB. If i'm correct, that should be more than enough to run HitFilm...My CPU is good too. It's an AMD Phenom II N930 Quad Core 2.00 Ghz. Can someone please tell me how to get hitfilm to stop being so slow??
    Thanks in advance

    Hi,
    Sorry for the problems you've been experiencing.
    I would firstly make sure your graphics drivers are up to date, I'm not sure what Operating System you are on, otherwise I would directly link to the latest driver. But I have enclosed a link to the driver download page below:
    AMD Driver Download
    Also the pre-made 3D particle effects are the most intensive to render and won't often render in real-time (although we'll be working on improving this). Sometimes you can get significantly more performance from building your own in the particle system.
    Thanks
    Ady
  • Thank you very much for the speedy reply...seeings as how I don't think I have ever updated my graphics card drivers (ouch...) and I am still using quicktime 4, I have some updating to do...that is probably the problem. (FYI I have Windows 7 64 bit). On another note, the software took 4 hours to render a 4 second piece of footage...there were 6-7 particle effects in that piece of footage, however, it shouldn't have taken that long. Was that caused by the same thing (outdated graphics drivers) too? From the looks of things, I think it probably is...I'll try rendering again as soon as quicktime and the drivers are updated.
  • Ok...I installed the latest quicktime and updated the drivers for my video card....nothing. No change in performance at all. Even rebooted my computer 3 times. Nada. Still won't even play a video back properly. Interestingly enough, I noticed no change in playback speed even when I changed the preview quality from Full to quarter. Changing the resolution from 1080p to 200 x 200 doesn't seem to have any effect either. I did get a strange error message when I started though...it said something like "Error, you will be unable to import quicktime files into Hitfilm because of this error. Error code 45 (I think) Please reinstall to fix this. However, I can import quicktime files...it just won't play them back, and it's very slow. Please, can someone help me fix this? I was planning on finishing my entry for the contest today...but it's going so slow, I don't know if I'll be able to finish it in time...
  • AdyAdy Staff
    edited September 2011

    Ok...I installed the latest quicktime and updated the drivers for my video card....nothing. No change in performance at all. Even rebooted my computer 3 times. Nada. Still won't even play a video back properly. Interestingly enough, I noticed no change in playback speed even when I changed the preview quality from Full to quarter. Changing the resolution from 1080p to 200 x 200 doesn't seem to have any effect either. I did get a strange error message when I started though...it said something like "Error, you will be unable to import quicktime files into Hitfilm because of this error. Error code 45 (I think) Please reinstall to fix this. However, I can import quicktime files...it just won't play them back, and it's very slow. Please, can someone help me fix this? I was planning on finishing my entry for the contest today...but it's going so slow, I don't know if I'll be able to finish it in time...

    Hi,
    It sounds like the QuickTime installation didn't finish correctly, it might be best re-downloading & attempting to reinstall again.
    Can you also check you are running the latest version of HitFilm, you can do that by downloading the latest installer here.
    What type of files are using, .mp4 & .mov exclusively?
    Thanks
    Ady
  • I have tried Image sequence, MOV, WMV, and AVI formats. All give the same slow, skippy preview. I'll try re-downloading the installer...its wierd though...It said it installed correctly...
  • Re-installed quicktime. I also have the latest version of Hitfilm (I know this because I have the latest effects, such as 4 point colour gradient). I didn't get an error this time around...but it seems to only give me that error message after I reboot my PC. The error code did mention re-installing HitFilm...could that possibly help? I'm running out of ideas... :(

  • I have tried Image sequence, MOV, WMV, and AVI formats. All give the same slow, skippy preview. I'll try re-downloading the installer...its wierd though...It said it installed correctly...

    Do you know what Codec your .AVI & .MOV files are using?
  • It's Windows Media Video 9...I don't think it has anything to do with the video though. The preview works fine when it's previewing nothing...also, HitFilm itself is just acting slowly. I have to wait a second or two after pressing a button to see the effects of pressing it. Hope that helps...

  • It's Windows Media Video 9...I don't think it has anything to do with the video though. The preview works fine when it's previewing nothing...also, HitFilm itself is just acting slowly. I have to wait a second or two after pressing a button to see the effects of pressing it. Hope that helps...

    So are you saying playback is slow when you have lots of Particle Effects within your Project? But Playback is fine when just playing back Media without Effects?
  • Oops...that was the WMV codec...the AVI codec is MJPG, and the MOV is Motion Jpeg B....Do you think re-installing will help? If I do re-install it...will I have to re-activate my serial key?
  • Not really...playback is always slow, no matter what. It gets even slower when particle effects are added. Also, as a whole, HitFilm is performing slowly, with a 1-2 second delay after I click a button. It gets even worse once particle effects are added. Rendering time averages one Hour per second of video with particle effects.
  • What I meant by saying the previewer works fine when previewing nothing is that when I have a blank project with nothing on the timeline, the previewer works (I can see the numbers moving smoothly, from 1 second to 2 seconds, etc.) But whenever I add any sort of media (image sequence, video) it slows down (the numbers go from 1 to 3, then to 4.5 then to 6...randomly etc.) HitFilm itself also starts acting sluggish around this time also. The demo did the same thing for me when I got it...

  • Not really...playback is always slow, no matter what. It gets even slower when particle effects are added. Also, as a whole, HitFilm is performing slowly, with a 1-2 second delay after I click a button. It gets even worse once particle effects are added. Rendering time averages one Hour per second of video with particle effects.

    You can change Particle Effects so that render in a Preview Mode. You can do this by expanding the properties for the General Section & ticking the box for 'Preview'
    That should help when editing Projects that contain lots of Particle Engines, you do have to do this for every one though.
  • Yeah...I found that already...it doesn't help any though. I actually have to physically turn all layers off/invisible except for the camera, and the particle effect I am currently working on to actually accomplish anything...otherwise, it takes like 30 seconds after I press a button to do anything...
  • Do you have any other software running that might be accessing your GPU?
  • Not as far as I'm concerned...I'm only running Google Chrome right now, and before, I went so far as to go into Task Manager and end every program I was running except HitFilm. I'm currently only using about half of my RAM and CPU capacity, before it was around 40%. It didn't affect performance at all. Out of curiosity, I actually have 2 GPUs, the 5650 and a much smaller, slower 4200. The 4200 kicks in on battery only. I am currently running the 5650. However, I was thinking that maybe HitFilm is for some reason mistakenly accessing and using the 4200 instead of the 5650? I don't even know if that is possible, but it does seem to explain the extreme slowness....
  • Okay...following up on my idea, I went into the device manager and completely disabled my 4200 graphics card. I can't say for sure yet...but the rendering seems to be going faster now since I disabled the 4200...just gotta wait for it to finish....still, its fairly slow...looks like it will be taking at least an hour, maybe two, for 7 seconds of video with 9 or 10 explosions, debris, and sci-fi shockwave effects. Is this normal??
  • Interesting! I can't really say much about that, it requires some more technical knowledge than I have, and I'll have to leave it to one of the devs to address that scenario. Unfortunately, I'm pretty sure they are all gone home for the weekend at this point, but someone will get back to you about that as soon as we can.
  • Ok...well, at least I should be able to finish the first half of my contest entry....No way I'll be able to get the second half done the way it's going now (its still quite slow...but there was a slight improvement when I disabled the video card...) At least it's something :P
  • Hey...umm...are any of the devs actually looking into this problem?? Because HitFilm still hasn't changed :( Its so slow that I actually can't use it...which is really frustrating, because the software looks so great :(

  • Hey...umm...are any of the devs actually looking into this problem?? Because HitFilm still hasn't changed :( Its so slow that I actually can't use it...which is really frustrating, because the software looks so great :(

    Hi,
    Would you mind raising a support ticket here.
    Talking to you on a one to one basis through a support system would be easier than responding to you here on the forums.
    Thanks
    Ady
  • Maybe you should buy new laptop/computer.. which computer are you using? Windows ten? it works fine for me  Though I have some problems with effects as well, it is going fine! 

This discussion has been closed.