Hangs constantly...

I downloaded and attempted to so something with the demo of HitFilm4 Pro on my Surface Pro 3, i7 512 GB. Windows 10, latest update (unfortunately... their autoupdate updates with far too much alacrity, and the latest updates have been more bug ridden than Swiss Cheese).

HitFilm4 has hung every time I've used it. The first few times, I added some folders, then attempted to import footage... right clicking hung it. Had to reboot (hard reboot, I couldn't even convince winblows to give me a task manager window). Tried again, clicked the import button, same result. Tried again, imported some footage directly, played it a bit, stuffed it into a folder since I need some footage from the other camera, hang.

 

Comments

  • That sounds very odd. A few thoughts/question spring to mind:

    1. Do you have any hard drives attached which might have gone to sleep? It's possible that HitFilm froze while Windows was faffing about waking those drives up, although even in that case it should only have paused for a moment.

    2. Do you have any Windows customisation utilities installed? These might be conflicting with the HF interface.

    3. Do you have any third party anti-virus/firewall software installed? A lot of Windows-based third party security software cause more problems than they solve.

    4. What kind of footage are you importing?

    5. What GPU does the Surface Pro 3 have? And does it do any kind of auto-switching between a low powered GPU and a fancy one?

    This is anomalous behaviour, so I'm thinking there must be something causing an unusual conflict somewhere.

  • The only one I can answer is GPU. The Surface Pro only has the integrated Intel HD 4000. Minimum spec for the software. 

  • 1. Yes, it's the drive I was importing footage from.

    2. None

    3. No, I've observed the same... I avoid 3rd party security software for that reason.

    4. ProRes, some of it HQ, some 444, all of it HD (I wouldn't expect this machine to handle 4K all that well... the integrated GPU isn't great)

    :-/

  • WhiteCranePhoto - Is it only importing footage that causes the lockups?

  • For me, last night, I was playing around with some single point tracking - I keyed the point to the handbag of a person walking down the street just to get used to the tracking features (haven't used them much).

    I decided to see what the stabilization would be like with the portion I tracked.

    I could scrub the timeline and see the track point remain steady as the edges of the video moved all around (as expected).

    But when I clicked the play button, the video would not play at all, HF4 froze, went white and after a time, I just closed it (losing my edit since I hadn't saved it.)

    Recreated the comp again, similar track, could scrub like before, but upon trying to playback (saved this time!), it again froze and crashed - quite repeatable...

    This was using some downloaded  Youtube MP4 1280x720 video file.

    -Will

     

  • I haven't tried much else... but I CAN import some footage. It's the same sort of behavior you get from an app that pops up a modal dialog that ends up being hidden behind it. The UI doesn't respond other than to give you a "ding" when you click on it, so you can't get to the modal dialog.

    The difference this time is that I couldn't get to anything else with alt-tab, or ctrl-shift-esc, either. My only option was to hard reboot. :-/

  • AdyAdy Staff
    edited November 2015

    WillBellJr - Your problem seems more specific to tracking, which is not what the OP is having trouble with. We have found an issue with tracking which we are in the process of fixing, so keep your eyes open for an update. :)

    @WhiteCranePhoto - As you're running in Demo Mode, it's possible a dialog is appearing behind the app . Does the footage you're importing footage have AC-3 / Dolby Audio? Do you have Auto Hide Taskbar on by any chance also?

  • edited December 2015

    @Ady, glad to see it wasn't just some "global" kind of freezing thing and my issue was related to tracking.

    -Will

  • The audio is linear PCM (recorded with a 633), and yes I do have audio hide taskbar enabled.

  • WhiteCranePhoto - Can you disable the Auto Hide Taskbar please? Does the dialog then come to the front?

    We have fixed the Auto Hide taskbar problem & it's ready for the next update so you don't need to disable Auto Hide for long.

    Ady

Sign in to comment

Leave a Comment