Cannot drag & drop media onto the timeline

Good evening & sorry to bother you.
I just bought Hitfilm and cannot place a video sequence onto the Editors timeline.
I checked the Project setting - they are matching the video properties.
If I am now try to drag&drop a sequence onto the Editors timeline I only see some kind of "prohibition sign" (is it called like this??). I watched the tutorials and cannot see that I'm making anything different like shown there.
(I run Hitfilm Ultimae Full Version on a Win7 64bit PC.)
Many thanks for your kind replies.


  • Hi Nuwanda, sorry to hear you're having problems.
    Please check out this article and let us know if it helps:
  • Hi Simon,
    GREAT - now it works ! Thank you :D
  • Great to know Nuwanda - let us know how you get on with the software. Be sure to check out the roadmap video below for more information on some of the things we'll be working on over the coming days, weeks and months. :)
  • just to add I too had this problem and was confused as all hell as to why it wasn't working! also wasn't allowign me to put in effects or properly play with my camera track/ but i've switched off the tablet features and sure enough it works. PHEW!
  • Good to hear, Uber. We're working on a proper fix for the drag and drop issue - it's a strange one!
  • Hi Guys,
    I was having this same problem and This is the only thread which seemed to have a solution, However, The link that Simon posted appears to be broken; it just takes me to the "your questions" page on my hitfilm profile could somebody please post the instructions on how to fix this or direct me to where I can find the answer? 
  • This bug was related to Wacom tablets, which were preventing drag and drop from working correctly in the program. This was fixed quite a while back, so it's unlikely that you're encountering the same problem unless you're running a VERY old version.
  •  Can someone tell me the fix? When I click the link, it just takes me to which is just I list of my questions. I cannot view the article. I am running HitFilm 4 Express. I too get the black prohibition sign when I try to drag a video to the timeline. I do use a Huion H610 Pro.

  • edited January 13

    I cant drag on and drop either please help

  • I'm having the same problem .Can't drag videos .Please help


  • edited March 13

    Is there a Hitfilm staff aroud here ? I have the same probleme using Express it says "invalid media" and in properties i can see "The media couldn't be imported" :/
    It's in ".MOV" and the properties are matching (29.9 fps ; 1080px720p)

    thanks for your help !



    EDIT: Since I installed Quicktime and did a copy (duplicate) of the files, it magiccallyy works ! don't ask me why or if Quicktime is necessary but now it works, hope it will help you !

  • Triem23Triem23 Moderator

    @Silafiann Quicktime is absolutely required for MOV files, so it's a good thing you downloaded it! 

  • I'm having the same problem, but the link Simon sent wasnt found??

  • @saraah Could you try to right click the HitFilm icon and run as administrator?

  • @CedricBonnier Still isn't working.

  •  @saraah could you please contact support if you haven't done so already?

  • Aladdin4dAladdin4d Moderator

    @saraah If you're running Windows, are you able to drag and drop files using file explorer like normal? I don't know if it would affect HitFilm or not but I just ran into a problem where you couldn't drag and drop anything in Windows. The fix was left click on a file and hold it, then tap the Escape key.

Sign in to comment