Anti Aliasing issues and more ...

Hi HitFilm team
i was very excited about the new HitFilm Ultimate 2 and upgrade immediately when it came out :)
but it seems i am out of lucky again as i am facing some important issues/bugs. the last time i had a important video project running (commercial work), i had to drop Hitfilm because of a Motion blur bug that made it impossible to use Hitfilm on that project (the motion blur bug got fixed after some time ... but it was to late for that project).
Now i am again with a important commercial project and i was sure that this time i could use Hitfilm Ultimate 2 ... but again there is a Motion blur bug (Blurs folder = Motion Blur) is totally unusable for me and produces heavy artefact's (the documentation on this is also very little) ..... this bug is actually not a big issue as there are workarounds.
but what about extruded text .... here motion blur dont work at all ... i try to make a composite with only the text in it first and see if this works ... but no ... it dont work (and with the Hitfilm update of today it still dont work !)
here again there is a workaround and i will have to import 3D text.
Now comes the thing that dont have any workaround and that will probable make me drop Hitflim again if there is no quick fix or other solution for it (because of the short time i got left for producing the final video).
i need to import a video and place it on a virtual monitor in 3D ..... if i zoom out with the camera, the video media is getting horrible Anti Aliasing artefact's .... it also happens if you use a normal image and try to reduce the scale or place the image farther away in z axis .... as soon the image get smaller, AA issues are visible.
the only way to improve the AA in Hitfilm was to make some changes to my graphic card settings ... but then the image get a bit blurry (a bit too blurry for me .... and it also seems that other type of artefact's appear after changing some graphic card settings).
is there a way to get this to work ?
my PC is a 2 xeon E5645 workstation with 24 GB RAM on Windows 7 64 bits
graphic card GTX 560Ti 1GB
i also tested it with my second PC which is a i7 3930k with 16GB on Windows 7 64bits
graphic card GTX 680 2G
i need desperately help on this because everything else is working fantastic in Hitfilm and i want to use it with the project i am doing right now !
i already installed the new Hitfilm Ultimate 2 bug fix of today ... but the issues are still there.
Greetings Patrick

Comments

  • here is a screen capture of the AA problem and i also have attached the HitFilm Ultimate 2 file.
    as you can see, the image quality is not usable ...
    [attachment=458:AA_bug.png]
    [attachment=459:AA_bug_01.zip]
    Greetings Patrick
  • just in case that this could be a workaround, here i post the settings for Anti Aliasing of my graphics card that seems to partly fix the issue .. but with a bit of image blur. see the image after the changes i made to the graphic card AA settings.
    but my question is ... we should not have to make any changes to our "default" graphic card settings .... right ?
    [attachment=460:AA_settings.jpg]
    [attachment=461:after_graphic_card_changes.png]
    but i noticed that after changing the graphic card AA settings, other "glitches" happen with HitFilm Ultimate 2 ... but i need to double check on this and see if i can reproduce the issue.
    Greetings Patrick
  • Try setting your preview window to "Render: anti-aliased" in the upper right hand corner of the screen if you haven't already.
  • Hi jonesbros
    yes i have set the preview render to Anti Aliasing ... did you try the HitFilm file i have posted ?
    i made some more test with the graphic card settings and i could nail it down to only 1 setting that makes a difference.
    i can reset my graphic card to factory default and then only change the "Anti Aliasing for Transparency" ... then the AA is better but the drawback is that the image get very blurry and again its not acceptable for production work.
    somebody else has noticed this Anti Aliasing issue ?
    is there something i can do to get a crisp image without this AA issue ?
    Greetings Patrick
  • Hi Patrick,
    I am pleased the software is working well for you. Thank you for raising these issues and we will look into them.
    As a quick workaround for your aliasing issues, are you able to create a plane with your grid texture in a 3d modelling package. If you import the 3d model as .obj, .lwo or .3ds you can achieve fewer aliasing artefacts without adjusting your graphics card settings.
  • Hi Rob Laycock
    thank you very much for answering so fast :)
    what you suggest would be fine but i need to use a video and for 3D models we only can use still image.
    i used the grid texture only to show the issue .... what i need is that a video that i place in 3D space don't get those AA artefact's.
    but i also noticed that there are also some AA issues on 3D models too ... not that heavy like on videos but still quite notable (they also improve with the graphic card AA settings).
    i will try one more workaround ... maybe adding a extrusion or parallax effect to the video could fix the issue as they have some extra settings like "supersampling" .... its not ideal .... but maybe it works until we have a fix.
    Greetings Patrick
  • OK .... i find a workaround :D
    i can restore my graphic card to factory default and still get usable AA on videos or Images in 3D space.
    instead of using a 3D model (which only allow still images and not videos), i use the 3D extrude effect with 0.0 depth.
    now .... if you also want to have working motion blur, don't parent the extrusion effect to a point like we do with text to make 3D text (position / transform from / none) ..... in this case, make the video layer 3D and parent it directly to the point layer in the time line. this way motion blur works again (actually you don't need to parent the 3D video layer to a point, you can animate directly the layer if you want .... but i just have the habit to move things with points).
    i am not 100% satisfied with this workaround as it also produces notable blur on the image/video ... but its better then using the graphics card settings.
    i hope this issue can get fixed quickly with quick bug fix update
    Greetings Patrick
  • How about a screen shot so we can see the difference? When you get a chance.
  • edited November 2012
    Hi snelldl
    here i have attached a comparison with a image in 3D space with 3D extrusion and without .... the difference is not that big but the AA with 3D extrusion is better (it also depends on the image/video you are using, you can see more AA issues when not using the 3D extrusion effect)
    image in 3D space default
    [attachment=471:3D_image_normal_01.png]
    with 3D extrusion
    [attachment=472:3D_image_3D_extrusion_supersampled_02.png]
    but now comes the next big problem ... if i use the 3D extrusion to avoid AA issues, the image or video will get blurred a lot ! especially if you get closer to the image (actual image/video size ... the image is not scaled ). the fact is that Hitfilm Ultimate only renders crisp images if the layer is 2D ... as soon you switch the layer to 3D, the image get blurred and if we use the 3D extrusion effect on it , then it get even more blurred which makes this method not usable at all ....

    2D image default
    [attachment=473:2D_image_default.png]
    3D image default
    [attachment=474:3D_image_default.png]
    3D image with 3D extrusion
    [attachment=475:3D_image_3D_extrusion.png]
    this needs a urgent fix ! i can not use it with this output quality.
    Greetings Patrick
  • That makes it fairly obvious. Hopefully our buddies can figure it out.
  • This issue is being looked into.

Sign in to comment