[Resolved] Video Export Settings leading to video ratio change

edited February 6 in Express Support

Hi, I have this video export parameters/format issue which is driving me crazy ! Typically, I am trying to export my video clip in the same size format as it looks inside Hitfilm but somehow when I export it either :

- adds black layers on top or on the side of the video, or

- modifies the aspect ratio of the video, or both...

I have addressed the problem so far by doing a Youtube export to my channel and then downloading it back to my computer. But now I can't (Youtube don't allow me anymore)

So, this is the format of my project :

width : 1440 pixels

Height : 1080 pixels

Frame rate : 25

Aspect ratio : HD Anamorphic 1080 (1.33)

Sample audio : 44100Hz

Rendering Mode: 4x MSAA

Shadow Map Size : 2048 pixels

I don't know how I got the aspect ratio set to "HD Anamorphic 1080 (1.33)" and I suspect the problem comes from here but now my project is complete and I can't change it without re-editing everything. Not an option....

So I think I have tried pretty much all existing Mp4 Export Settings, hoping that the format of the video will remain but it always modify the ratio or add back layers on the side/top.

When I export to You directly, the format remains fine so there must be a setting which should allow to export my video as it is. 

If you can help, it would be very very very much appreciated !

Thanks

F&S

Comments

  • Which version of HitFilm are you using?  Because you mention YouTube export in a couple places, I'm thinking it might be HitFilm 4 Express.  If that's the case, have you considered updating to the most recent version, HitFilm Express 2017?  It's got a completely revamped export system, which might make it easier to get an export that matches your project resolution.

    On that note, you said:

    "I don't know how I got the aspect ratio set to 'HD Anamorphic 1080 (1.33)'"

    My gut tells me that you dropped a clip with that resolution into the main Editor timeline, and when the dialog appeared asking if you wanted to change your project settings to match the clip, you clicked "Yes" and possibly also the checkbox to never ask this question again.

  • Hi Jsbarett, I am using Express 4.0.0146 (update 8).

    I can try the new version indeed.

    I possibly did what you said about accepting resolution change but anyway there should be a proper export setting now which should allow me to not distort the image while exporting. Any guess how to do ?

    It is done when I export to Youtube... (sigh) :(

  • Triem23Triem23 Moderator

    Can you download MediaInfo (it's free) and generate a tree report on both one of your source files and an render file? This will help us figure out what's going on.

    https://mediaarea.net/en/MediaInfo/Download

    Reading the thread, here's my first thoughts. Video resolutions are fairly standardized, and, if you're looking for a full-screen 16:9 image, like that on TV's and the majority of monitors, well.... that's a resolution of 1920x1080. Your 1440x1080 video strongly indicated video that should be output with a pixel aspect ratio of 1.33. This stretches out the 1440x1080 video to 1920x1080.

    In this case "distortion" is caused by not properly setting the pixel aspect ratio on export. In Hitfilm 4, this is the Aspect Ratio control in the Export panel, and should be set to 1.33. Export resolution should be set to 1440x1080.

  • @Triem23 My tests show that the export resolution should be set to 1920x1080, aspect ratio to 1.33, and Scale Mode to "Ignore Aspect Ratio."  Otherwise the output appears squashed horizontally, which is one of the problems the OP originally mentioned.

  • Waoo, you guys are genius !! 

    You fixed it. With 1920x1080, ratio 1.33 and ignore ratio settings, it keeps the original ratio. I will not ask you why it works now, I think I'm not gonna get it.

    But is there a project setting that I should consider keeping as standard in order to avoid this kind of issue in the future ? (square pixel, a certain image ratio,...)

    Thanks a lot for the help guys !! :) 

     

  • First, open the HitFilm settings (click File, then the Options button with the gear on it).  On the Prompts and Warnings tab, make sure that "Prompt when media doesn't match timeline" is checked.

    When you start your next project, assuming you want a standard 1080p resolution with square pixels, set that as your project preset.

    Before dragging any media into HitFilm, transcode all videos to convert anything that's 1440x1080 HD Anamorphic 1.33 into 1920x1080 with square pixels. MPEG Streamclip is one transcoding tool available for both Windows and Mac OS.  A rough outline of how to use it is included in this video, along with more about the benefits of transcoding:

    https://www.youtube.com/watch?v=Yqhl0mRuTng

  • Will do jsbarett ! 

    Thanks again for the help and advice !

    Cheers

Sign in to comment

Leave a Comment