mocha Hitfilm confusion!!!!

I am hoping someone can help me!!

I have tracked a scene in mocha hit film. 99% accuracy, grids and planer surface are all good in mocha. When I bring it back into hitfilm, I am having major problems with trying to get stuff to line up. 

The main thing that is throwing me, is that when using the perspective view, top, right views etc, a load of the tracked points are all 'behind' the camera. The 'real' filmed scene is a simple shot, nothing crazy, and clearly everything is in front of the camera (foreground plane, background plane, and floor plane). To my understanding, when in perspective view, you should be able to see all the track points (if they are all in view in the real tracked footage of course), with more distant points further back in z-space and elements that were closer to the camera closer in z-space (like if you set up 3d points etc in a full CG comp shot). Surely tracked points that are in view in the footage shouldn't be 'behind' the 3d camera that was solved in mocha?!?

When i bring any 3d element in, and parent it to a mocha tracked point, it IS in 3d space, but nowhere at all near to when it should be. I have reset position, tried playing with anchor points etc and cannot get it to stick where I want it in 3d space without a massive amount of just moving the the position about to get it in the right position. However, if I move it into the visually correct position, and use the top/right/perspective view etc, the 3d element is absolutely nowhere near the parented mocha point, even though it is now visually correct. This is proving a nightmare to get it to stick, as I have no reference for the Z space at all, and I am just trialling and error-ing to move it about in z space to get rid of the obvious parallax shifts!

Best example i can give, is parenting it to a foreground element track in mocha. The mocha tracked point, is shown in perspective view as being WAY behind the camera, so when i parent an element to it, it isn't in front of the camera, and therefore you can't see it (even with resetting its position to the parented point)! I have to move it around '5000' in Z space just to get it in front of the camera so I can see it! So its now nowhere near the parented point! It is proving very frustrating, as all I am trying to do is get a 3d model to fly through the sky from back left to front right, but it is so confusing and illogical trying to animate it when none of the points correspond to anything in the perspective views, and I can't even get a 2d photo to stick to a wall!

I am sure I am doing something wrong , and have tried the whole parenting everything to a new point and lining it up with the floor thing, and I still can't get it to make any sense! The 3d element z-space blue arrows are also pointing in different directions to the mocha tracked point, suggesting I need to do something to get it lined up, but I cannot work out what!

I know this is probably not a great explanation, however if anyone can offer any advice it would be greatly appreciated! 

I can't even just get a 2d photo to stick to a wall at the minute, as its so ridiculously far off the mocha tracked points, its actually easier and quicker to do it by key framing! Surely this shouldn't be the case!!! In After Effects you track the shot, click 3 points on a wall, create plane, and thats its....stuck to the wall in 3d space! I can't even get stuff close without a LOT of faffing around in Hitfilm/Mocha! I know I am doing something wrong here, and if anyone can help me out it would be massively appreciated!!!

Hitfilm is awesome, and I know its something I am doing wrong, and if someone can tell me what, I will send cakes via post immediately!

 

Comments

  • i am having the same trouble ?? did you ever figure it out every thing else is working good just getting things to stick is the problem not sure how to do it??

  • It's a mocha problem. Sometimes it puts the points behind the camera, even with a good solve.

    The best you can do is add more planes and/or change those you used to solve, twiddle with all the settings until it gets it the right way around.

    Best bet is to watch a few official mocha tracking tutorials.

  • @adamsfilms12

    this has helped me in the past when I could not keep the assets from drifting.

     

    https://www.youtube.com/watch?v=32NJS_SIuFM

  • Have you got your scene setup right. Nearest layer to camera at the top further away at the bottom of stack. Layer placement is important. Maybe something to do with that

Sign in to comment