Hitfilm Pro 2017 Won't Start

No Error Message or anything it just wont turn on, but  when i tried to re download it i accidently dowloaded Hitfilm Pro and that started up fine.... but i need 2017 because thats the one i bought.

Desktop

Specs

Graphics Card

AMD Radeon HD 8370D

Proccessor

AMD A4-6300

7.80 RAM

64 bit

 

 

 

 

Comments

  • I have the same issue with 2017. I've tried repairing it, uninstalling and reinstalling but it just won't open. It formally says it has encountered a problem and I've sent along the requested log dump from the various attempts.

    It's been a while since I opened the program so a Win10 update may be the culprit.

  •  Same here but with Windows 7 Pro. HF Pro 2017 has launched in the past just fine. When I  tried to launch again yesterday after a few months, I had added a SSD C drive in the interim, by the way, got the HitFilm "New Version" message but there was no description in the box so I tried to skip it and nothing happened. Checked the "Task Manager" and there seems to be multiple versions of HitFilm running. So I delete them and try again but nothing happens. I "Deactivated" HF, uninstalled and re-installed still nothing happens at launch...this is very bad! I'm a bit clueless anyway but this has got me.

  • edited January 7

    Hmmm. I just reinstalled HitFilm Pro 2017 on my Win 10 Pro machine after having it completely overhauled (a brand new machine, mind you, where Microsoft updates corrupted the OS). It works fine, BUT. There is an error message that claims the program malfunctioned, specifically hitfilmclientrender.exe or something like that. Hit the close button, program continued to stay up, so I tried, first a simple image sequence and it rendered it fine. Then I went to a series of video sequences, and, ultimately, some heavy effects in comps. Everything rendered fine ...so far. Haven't tried it since the latest patches from MicroSoft, though.

    I, like these folks, am not interested in buying the latest HitFilm Pro. I like 2017 and haven't even scratched the surface of mastering it, so I'm not going for bigger/better. I think it's all I need, and, hopefully, you folks will continue to support it. Meanwhile, though, there are these gremlins happening.

    Here's a image sequence of screen captures.

    https://youtu.be/VHMb7M5EeSU

  • @CedricBonnier ...okay. I'm not sure that I'll be able to supply the correct phraseology to communicate the problem, but I'll give it the old college try, I guess. Sigh. 

  • Anyone have any luck yet? I've been dealing with support but it's been weeks now. Even though I rarely find time to use it, I'd still like it to open.

  • @Farscape have you tried the Demo of HitFilm 6? I'm not suggesting you should buy it, just try the free demo to see if this launches or not. It may help us identify the issue. Are you on Mac or Windows? What are your system specs? Have you got an Intel HD 530 or similar? We're currently trying to solve issues with this card on HitFilm 6. What is your exact driver version number?

  •  On Windows 10 with latest bios and graphics card drivers. Custom build with 850w power supply.

    System specs https://d.pr/i/FxRVEu/blEXqSCIE6

    It is an XFX AMD R9 280 with Adrenalin Edition 17.12.2, also tried .1.

    The Hitfilm 6 demo I just installed opens as 2017 once did without issue.

Sign in to comment

Leave a Comment