End Credits Crawl Effect Not Working

I'm using the end credits effect for, well, the end credits of a short film I made. However, every time on export, the line spacing seems to have doubled.

When I went back to fix it, the value was the same, but the spacing wrong. I reduced it as low as possible (still not the right spacing) and tried again, but the same thing happened! Any help is greatly appreciated.

Comments

  • It looks fine in the editor and compositor, just the final video it changes, as well as when I re-open the software to see what's wrong.

  • Hmm. It seems every time I re-open the project there is an added space every time there is a line break in the text boxes.

  • I removed the extra spaces and re-export. No problems. I re-opened the project and, no problems! Weird. This might be a bug in Pro 2017, but anyways my project is fixed, and hopefully it doesn't happen in the future.

  • I think it is a bug, I too saw this in HF pro 2017 and fixed it like you did.

  • @Andy001z glad I'm not the only one then :)

  • Hitfilm Express 2017 here, same problem.

    Very annoying, trying to fix, but can't find the extra spaces.

  • A question for both @ZachAlan_Productions and @HiFi...

    How did you get your credit text into HitFilm?  Did you type it in manually, or copy and paste it from another application?  Also, what platform are you each running (Win/Mac)?  If my hunch is correct and you copy-pasted the text, I suspect the newline character data isn't being stored/handled correctly.

  • There is a bug in the Text effect which is the same: Every newline character seems to be doubled on every load/save. Even when typed in instead of copy/paste. Maybe the end credit effect is affected by the same bug.

  • Odd. I've never seen that behavior, and have been using text in HitFilm for several years.  What platform are you on, and which version of HitFilm is exhibiting this behavior?

  • @jsbarrett I typed the text, not copied and pasted. I experienced this issue on Windows 10 in both HF Pro 2017 and Version 6. I have had this issue with the end credits crawl and the title in the Star Wars crawl.

  • It may be a Windows-only thing, as I've never seen this behavior in the Mac versions.

  • I've also reported the bug with the new HF6 text effect and newline character multiplying. It happens on project save and is intermittent. Intermittent but at a very high percentage for me.

    Given that the new text effect is probably using the same engine as the credits crawl, it would not surprise me if the same bug exists in both.

    I've never used the credits crawl, but I have been hammered by this issue in the new HF6 text effect.

  • edited January 16

    The bug always gets me. I spend a long time exporting a project I thought was finally done, and then the text is messed up. Oh well. Easy fix I guess... Hopefully this bug gets fixed soon.

  • We are aware of this issue but unfortunately haven't had time to fix it yet. Thanks for your patience and sorry for the inconvenience.

  • Whenever I come across an annoying big or more often my annoying stupidity I just export that sequence ( egg credit scroll) separately until I get it right and then put it into the big project so long waiting for exporting isn't ways 

Sign in to comment

Leave a Comment