Composite Shot Clip Trims When Inserted to Editor

Hello everyone so I am currently using Hitfilm 4 Express to make gaming videos. I record on my phone and then edit here in Hitfilm. I have a clip that was recorded unevenly so I want to create a Composite shot->Mask Tool->Rectangular Mask to trim it slightly off the corners in order to get a good clip. However, my clips once added from composite to my editor seem to zoom in even more than what I had left it as. I have tried to zoom out and even when I don't use the mask tool they still appear in editor more zoomed in than usual. Also my clips always appear upside down so I have to manually rotate. Thank you all in advance!

 

Comments

  • Also if you could guide me as to how to add images from my desktop to this post it might help everyone. 

  • Working backwards, the forum won't host images.  You need to upload them somewhere, then add the link to them using the Insert/Edit Image button in the comment toolbar.  imgur.com is a good free resource for image hosting, but it's just one of many.

    To your original question, there are several factors at play here, all regarding resolution, which leads me to the following questions:

    1. What resolution is your project?
    2. What resolution is the video coming from your phone?
    3. What resolution are the comps you're making when you want to mask the videos?

     

  • Triem23Triem23 Moderator

    @jsbarrett has probably figured this out. Sounds like you're loading screen caps into a lower res Composite Shot. For sake of Argument lets say you've loaded 2560x1440 footage into a 1920x1080 comp. The comp is lower resolution so your video is zoomed in.

    You can manually scale it down using the Scale option in a layer's Properties. 

  • edited January 12

    1. 1080p Full HD @ 60 fps

    2. My video is at QHD 2560x1440

    3. 1080p Full HD @ 60 fps

    Okay so I read from both of your posts and changed my project and my composite to 1440p QHD @ 60 fps and now it all fits correctly! Thank you both so much for your help!

Sign in to comment

Leave a Comment