Text Layer not working correctly with Set Matte. Can't seem to figure out why.

I tried doing this with a composite shot containing the matte:

https://imgur.com/08cGtZh

The idea is that the text, when moved past the black, will go invisible:

https://youtu.be/5GsJCPz8WNw

However, as I set the text layer's matte to the composite shot containing it, some weird thing happens. 1) It does not go invisible, and 2) the area containing the white shows. And in black:

https://youtu.be/oPkOKbZIumQ

Just incase, I intended for the matte not to show at all, of course, so I have its visibility toggled. I have the Set Matte settings to:

Matte Source: Luminance
Blend: Add
Invert: Disabled

Am I missing something? 

Thank you!

Comments

  • edited January 8

    Never mind. I was just guessing. :)

  • Triem23Triem23 Moderator

    Simpler than what Palacono said, try shifting the Set Matte from Luma to Alpha. Change Blend from Add to Replace. 

  • edited January 7

     @Palacono @Triem23 Neither of the solutions worked successfully. I did try the solutions separately, but they resulted in the same picture:
    https://imgur.com/epXh0YI


    I was able to fix it somehow using the following settings instead:

    Matte Source: Luminance
    Blend: Subtract
    Invert: Enabled
    https://youtu.be/dyMXCOKNL7g

    I sort of just fiddled around. Blend modes aren't my strong suit, so honestly I don't understand how it worked. Might any of you have an idea? So far I get that the inversion changes the white to black and vice versa.

  • Even easier still, you don't need to do anything in a separate composite shot.  Just use a plane in the same comp as your text, position it so that its edge is where you want the other layer(s) to begin (dis)appearing, then turn off its visibility.  On the layer with Set Matte, target the plane, set Matte Source to Alpha, Blend to Subtract, and if needed check the Invert box.  Much easier to modify this on the fly than fiddling with a separate composite.

Sign in to comment