3D models overlapping

Hi,

I'm a hitfilm 2017 pro user.

I'm experimenting the particle simulator with custom textures, using a stormtrooper 3D model to build an army.

I have an issue in the final rendered output where some troopers in the background appear in front of some foreground troopers, overlapping them. And I can't figure out why it happens.

Please can you assist ? 

You can see the video here: https://youtu.be/jfeHWDjlbi4

You can download the project here: https://drive.google.com/open?id=1lHAdmQNvoS4fciMqGWMUhKXFrA5kz1m4

Thank you!

Regards,

Stephane

Comments

  • Triem23Triem23 Moderator

    I think you might have found a bug? I can fix the sorting order by changing from 3D unrolled to 2D, and moving the floor plane to a lower layer but the the lights become a lot harsher, then.

    @Aladdin4D @NormanPCN ?

    I looked at the materials, too.

  • edited January 5

    I was working on a shot very similar except the troopers are walking. As for the model, it has something weird going on with it that seem to cast shadows on itself even though they are not turned on. I found that an environment map took care of that. ??

    <-- Video removed --> 

    As for overlaying models..I did as Mike suggested but I still see the front middle model has 2 models (overlayed on each other) ....delayed every so slightly. Weird.

    (vid will be removed)

  • GreyMotion, Where did you get the walking Models. I only have the free one in the tutorial.
    I did notice you have to have the main single model turned off or it gets mixed in with the clones.

  • If center of mass is not used everything is fine. As soon as values are altered things mess up. I checked it with a more simple 3d object and got the same issue here.

  • If I swith "Intersect layers" on it also looks  good. I think that is the solution.

  • Triem23Triem23 Moderator

    @Juda, so setting center of mass to 0,0,0 fixes the issue? 

  • @Triem23: Yes. But also Setting "intersect layers" fixes it with leaving Center mass like it was.

  • Triem23Triem23 Moderator

    @Juda1 ah, dammit, Intersect was what I was looking for and couldn't find earlier! Yes thats the toggle. The reason it can be turned off if it doesn't matter for things like fire and smoke 

  • edited January 5

    @nealtucker Take your .FBX model over to Mixamo and generate a new movement . Be aware that a walking animation is only about 3 seconds long. 

    For the record- center mass to 0,0,0 doesn't fix the overlay issue nor does intersect layer and yes...hero model is not showing. Weird. I'll have to explore this at some point.

  • Center of mass moves the particle texture off of its coordinate position. This example uses center of mass (COM) on particle movement variation. Therefore this offset is random.

    I took this example and turned the grid effect OFF of the floor plane. The grid creates transparency which can affect things. Somewhat randomly I believe.

    With a solid floor plane you can see that many troopers disappear. This is because their COM offset moved them below the solid floor plane. Without intersect layers enabled a texture is either 100% above or 100% below another 3D layer. So the trooper appears or disappears. Also the floor plane is not deep enough for all the troopers so some troopers in the back do not get occluded at all. If a trooper in front is occluded by the floor a smaller trooper in back seems to appear in front.

    With the grid effect on it probably depends on if a given troopers position is over transparency of the grid with respect to occlusion of a given particle "texture". I think it randomizes, or makes it more visually confusing, what is going on.

    The COM movement is very small. Even if the offset moves the trooper down, with intersect on, not very much of the troopers foot will get occluded (chopped off) due to the intersection with the floor.

    That is what I see going and an why I think it is going on.

    Screen shots. Intersect OFF.

    Intersect ON

  • You're great guys! Switching on the intersect layers and set the COM to 0 fixed it: https://youtu.be/t8HOkMBMpek

     

    Thank you all for your help!

    cheers

    Stephane

  • edited January 6

    The front right particle texture is not drawn but the shadow from the particle texture is still cast. Should this be the case? Maybe something for Development to talk about.

    Cast shadows if visibility is off, is not enabled on the particle layer. 

    I'll be so forward as to tag @CedricBonnier on this.

    EDIT: Zooming and panning around in I can see the tops of the front troopers behind the plane. So I guess they, the "not drawn" particles are there at some level.

  • edited January 6

    @bodzebod74 Your front center (there is one more behind him to left as well) model is actually 2 models. Look closely. I get the same thing with those settings. This should not be the case.

    EDIT: I dropped the particles per sec to 98. Started at frame 1. Duplicate models disappear??? Checking the particle count manually from the top view there are 10 rows of ten but only 98 particles?? Math was my worst subject

  • edited January 6

    I do see the duplicate particle/models. At points during the animation the overlapping models are out of sync in movement. Then you see it.

    The timeshift is -1.0s and particles per second is 100. With that there is a duplicate or two in the grid. At 99 particles per second we get a gap or two in the grid. It might be a little hard to get exactly 100 particles to exactly fill a 10x10 grid.

  • edited January 6

    Might be the case ..yea.

    One other thing..the shadows are for terrible with the particle system as has been mentioned before on other threads.

    I went back to unrolled  with 98 particles, unticked Intersect, left COM at 0,0,0. The particle system looks perfect. No offset at all and clean shadows. Of course with a -1.0 sec time shift I shouldn't have to start at frame 1. The particles should have all spawned at 0?

     

    https://www.youtube.com/watch?v=yP4tWVo-dqQ

  • Whoa, cool. :)

  • I would like to know how Long Rendering took for you? I got an I7-7700 3.6/4.2 Ghz with NVidia VTX 1050 TI here. When I Import that Project AS IS, relink the media and render in/out Point it takes nearly one hour to render those 7 seconds. I know hitfilm is only using one core but this Looks too slow for me regarding how fast you guys answered here.

  • Triem23Triem23 Moderator

    I wouldn't be surprised at that render time. 3D model particles slow the system down, then having the animation offset slows things down more. 

    I think GrayMotion has a 1070. That's a significantly faster card than a 1050. I have a 980m, which is about the same speed. I don't remember Norman's.

    I don't think Norman did a full render. Neither did I. 

  • The calculation Speed of 1070 is faster of Course. Since my GPU Shows 1-2% (max) usage this is not the bottleneck at all. I think the GPU doesn't matter at this Point when usage is so low. The CPU Shows 15-20% usage. Tha nearly Comes to one core fully used so I think the bottleneck is that Rendering takes place in one core/thread only.

    BTW: Are there any Options suggested for the Nvidia Settings? I dodn't Change anything yet but there are so many Options so I wonder if anything can be speeded up.

  • Triem23Triem23 Moderator

    @NormanPCN @Aladdin4d or @Stargazer54 would be the ones to ask about Nvidia settings. 

    The Particle Sim uses CPU for physics and animation calculations then the GPU to render. Sounds like ofsetting the animation data is pegging the core. 

  • edited January 7

     @Juda1  Render time took 9 minutes for the 30 sec clip. The render client's average CPU usage is 17%, utilizing 1016mb memory.

  •  @graymotion kann you send me the Project file you used? Lighning and reflections look different from the origial Project file.

  • The render time is crazy slow with motion blur on but that is a common thing with motion blur. Especially this case. 100 models that each need motion blur calculated on.

    The project I downloaded looks different than that uploaded by GrayMotion. Mine has no camera moves and the lighting is different. Only one light. Motion blur was enabled on the particle sim layer.

    With motion blur off that project take 9:50 to render. With motion blur on, I did not do a full render as that was estimated a 2.5-4 hours after about 3% complete.

    Exports or ram preview are not the best test cases for hardware utilization in Hitfilm. They always take a big drop on these things in Hitfilm. Probably due to a GPU readback operation. It does not matter why. It just is.

  • All of what NormanPCN said. I simply went overboard on a "boring" shot. I'm of the thinking that if I'm going to use power to render it might as well look a smidgen decent .  I'm just guessing that a full on scene complete with background, 3 lights, flares, motion blur and chromatic aberration would take 8-10 hrs for 7sec. 

    My true interest in the OP's post was the model overlaying in the particle system. I had tried setting up a squad of walking troopers a few weeks ago but they started at random times and would not align properly in a 10x10 grid with 100 particles. Not the way it's suppose to work I don't think. So I parked the project but then when I saw this post about the same "type" of problem my interest was peaked.  Definitely something a bit wonky with the particle system. 

    @Juda1 - it is literally the same scene assets. All I did was move the floor and background layer under the model in the stack, added one more light (keep lights with 500 in all directions), animated the camera and tweak the models cook-torrence settings (diffuse, specular).  Diffuse color is 204, 204, 204 - Specular is 157,157,157

    Shinny comes from specular reflectance and roughness - they are at 5%. Overall brightness of the model comes from diffuse reflectivity - that's at 18%  AND Index of Refraction (1.4) and Refraction amount 13%

    Also I set the projects Shadow Map size to 4096 (if you have strong enough PC) in the project settings. BTW - The diffuse map for this trooper is awful grey so really hard to get something shinny white.

    Hope that helps

  • edited January 8

    Thanks al lot. I really was thinking like "what the f..." is wrong with my computer which is one month old. Without motion blut I render in  under 10 Minutes, with it took 1 hour 20 for a 7 seconds clip. 

    I already got some sort of shocked when I downloaded the Christmas puppet tool Project last week. I couldn't even scrubb the timeline while Javert's tutorial looked so smooth. Until I found out that the exposure effect on two Images was an extreme handbrake. 

    I'm fairly new to hitfilm and did 2D / 2.5D with Vegas before so I never had complex projects that slowed down the Performance so much. Now slowly but surely Things are getting clearer to me :)

  • Juda1, same for me. I got a top of the range PC last month to use with HF but that Puppet tool project nearly killed it. Like Trem said we need the render settings more accessible so we can turn things on and off quickly.
    I'm sure the Devs are working on improving the performance of HF, AE does seem smoother and quicker to me on my new PC, Scrubbing the timeline is very smooth in AE. 

  • Triem23Triem23 Moderator

    I'll do a test render for funsies, but I poked deeper into the project, and noticed textures were sent to "Billboard."

    That setting automatically aligns 2D textures towards the camera, and I noticed turning that off eliminated some of the artifacts. Presumably the 3D animation data is trying to override the Billboard, but having that setting oon is causing confusion in the render as the sim tries to orient and not orient particles to camera at the same time. After that, checking Intersect Layers seems to have taken care of the rest. This is leaving the layer as 3D unrolled.

    Still good if I turn the layer 2D.

    Starting two test rendes. Back later.

Sign in to comment

Leave a Comment