How do I make a shadow catcher?

I want to place some text in a scene, put a light behind it and have it cast a shadow on the ground in a video, where I'll place a plane at the same angle as the ground so it looks correct.

I can do this with a light and casting the shadow onto the plane OK, but I want just the shadow, so it'll look like it's on the video's ground and not the plane itself. Various blend modes for the plane don't work and a Set Matte using the plane as a source seems overkill, so I'm stumped.

Probably something simple I'm missing, anyone care to point out what that is? :)

Comments

  • White Plane, Blend Mode to Multiply?

  • @Palacono You could fake the shadow by just using a drop shadow, and have the check the option shadow only. 

  • edited October 24

    @InScapeDigital Ah, that was it. Thanks. :)

    I'd gone through all the blend modes when I was using a grey plane and evidently didn't try them all again when I'd changed it to white later. Doh!

    Got it working with the shadow in another comp (on white) and using a Set Matte on that with Lightness and then a Fill Color to make it darker, then duplicated it because: still not dark enough, then added some Blur.

    Very "round the houses", but... multiple cat skinning techniques in Hitfilm :)

    Edit: Oops, I also need a extra light for the front of the text or it turns black, whereas the separate shadow method doesn't need a light because I just get the shadow shape from the shadow comp. An extra light is easy enough, but it might be six of one, half a dozen of the other for Hitfilm's workload on the two methods. :)

    Edit Edit: ...and I can't put Blur on the 'real' shadow. Oh well.

  • @Palacono You can turn off "Illuminated" in the text layer's Material properties to avoid needing another light. In the main light's setting, increase the Shadow Diffusion to add blur.

  • edited October 24

     @InScapeDigital ;
    Shadow Diffusion adjusted: Check. :)
    Illuminated Off in Text: No Check.

    Scratched head a bit before wondering if the 3D Extrusion on the text might be the problem: It was. Turn it Off and text is normal. On and it's black.

    But there is no 'Illuminated' checkbox equivalent in the 3D Extrusion effect...but changing Comp Lights to Selected Lights and...not selecting any = Bingo! 3D Extruded Text visible again. Phew! :)

    It's a shame that Extrusion doesn't cast a shadow, but you can't really tell with it behind the text. It would be more obvious if the light was more to the side, but it isn't.

  • Triem23Triem23 Moderator

    @Palacono general note for 3D Extrusion, Parallax and Caustics.

    The Illumination settings for those are independent to the Layer Materials. As you've noted, for a 2D layer this is the Illumination dropdown. If you ever use these effects on a 3D layer like parallax on a model, which does work..., turn off Illumination in the Layer materials or the 3D layer gets lit twice. 

Sign in to comment