Editing a composite shot

I have a 5 layer composite shot.   I select the 4th layer from the top and go to scale it down or up from one of the points on the rectangle or move it up or down with the green or red arrow.  As soon as I touch one of the corners of the rectangle or one of the arrows the selected layer deselects and the top layer is selected.    It happens time and again.  I select the layer I want to edit and as soon as I touch the screen the selected layer changes and often the layer that I select moves position to the top layer.   It's driving me crazy.  I spend more time trying to keep the layer I want to work on being the layer selected than anything else.  It also changes my workflow because sometimes I don't notice it and I've made changes that are affecting the top layer and not the selected layer so I have to undo.

Is anyone else experiencing this?  I haven't been using the Hitfilm 3 Pro software much but the last few days I have been and this problem is more than annoying.  Even if I turn off the top layer it still happens and it's really not ideal to do that because I have to be able to see what I'm doing doens't overflow into the top layer.

Comments

  • Triem23Triem23 Moderator

    When you click in the viewer panel, Hitfilm is going to attempt to select the object directly under the mouse pointer. However, if you have multiple objects it will try to select the object closest to camera. In 2D mode, or, if you have multiple 3D objects at the same co-ordinates, Hitfilm is going to select the object at the top of the layer stack. 

    So, let me guess. You have five 2D layers, and when you're grabbing the widget, Hitfilm is grabbing the top layer? 

    Ok, so that's why you're having the problem. Now, how to fix it? Unfortunately I just described Hitfilm's programmed behavior, and that's not going to change anytime soon. Therefore you're going to need to tweak your workflow a bit. Either do your initial scale/transform using the Controls panel or twirl down those options in the layer stack, or do your initial setup back-to-front/bottom-to-top. Once everything is sitting "in the same place" then the screen widgets should be more predictable. 

    Sorry--probably not the easy answer you wanted, but, as long as you know how Hitfilm is doing things, and why, you can work around it's idiosyncrasies. Similar things can happen with object selection in other compositors and 3D apps as well. 

  • HitFilmer289932 something else that might work, is try to disable the layers that you don't need to work on, this way they won't be in the preview window and won't therefore be selectable. If you need them to be on, I suggest you have a look at one of the Hitfilm Tuts on Layers, it explains how the layers work in a stack and the order of the stack effects which one is on the top. This is different in 2D and 3D planes.

    Good luck.

  • Triem23Triem23 Moderator
    edited October 2015

    Thing is, it probably takes longer to disable/enable layers and use the widget than it does to twirl down the Controls tab to use sliders, knobs, drags, and numeric entries. Plus, I Hitfilmer said he was disabling layers already. 

  • @Triem23 me bad, not reading his post v.well. It been a long week so far.

  • Triem23Triem23 Moderator

    I hear that! 

  • Yes I was disabling layers and it still went to the top layer.  I did notice that when I edit through the control panel there's no problem except that it takes some time getting the right coordinates.

    After writing that post I found that if you click right on the rectangle to transform or dead on the green or red arrow then it happens much less.  I'm using a Wacom tablet and that also takes some getting used to.

    Thanks for the help.

Sign in to comment

Leave a Comment