Problem with Alpha property in Particle Simulator with Layer emitter

Here is a screenshot of my setup. Here is the Project file.

Hitfilm 3 Pro, Windows 7, i7 4770k 4Ghz, 16GB, AMD 7950 3GB, driver 15.7.1

I am trying to do an Aurora Borealis with the wiggling we see in typical timelapse video. I am using an atomic particles comp to create a line and wiggle it around with fractal movement. I then add Demult to get an alpha channel. I use this layer as an emitter in the particle simulator. The screen shot shows this with the AtomicP layer still visible.

My problem is that the Alpha particle appearance property has no effect when the layer is used as the emitter. The particle textures are always 100% opacity no matter the setting. The particle Alpha lifetime setting is OFF. Change the emitter to any other type, with no other changes, and the Alpha property works as expected. I believe Alpha should work with this layer emitter as it does with other emitters and I believe I have it setup properly.

Comments

  • EmmaEmma Staff
    edited August 2015

    I've taken a look at your project file, NormanPCN. You're correct that when particles are spawned from a Layer emitter, and 'Shape > Use Layer Alpha' is checked, the 'Appearance > Alpha' property gets ignored.

    This is because when 'Shape > Use Layer Alpha' is checked it determines what positions particles can be spawned from on the layer (they can only be spawned from pixels whose alpha is greater than the 'Shape > Alpha Threshold') and it sets the alpha of the particles to the alpha of the pixel on the layer the particle is spawned from.

    In this case, it seems that you want the alpha of the particles to be different to the alpha of the layer, but need the 'Use Layer Alpha' option checked to determine where particles are spawned. If you combine keyframing the opacity of the Particle Simulator layer (or apply a grade layer to it) with some tweaks to the lifetime alpha of the particles, hopefully you can get the effect you're looking for.

  • Thank you for your response.

    That makes sense. I was using the "Birth Alpha" option. I simply read the documentation that the "use layer alpha option" was only about particle birth and not additionally affecting the particle birth alpha value.

    I had already begun using the Lifetime Alpha feature to get lower particle alpha settings. It actually provides more control as well.

    One thing you may still want to look into. If you change the project to use the "Current Alpha" appearance option, by my reading, the documentation indicates that with this option the Alpha setting value should probably be used in that instance. It is not.

    Thanks for pointing out the particle is birthed with the layer emitter alpha value. That ability actually  solves a problem I was having, and I have adjusted my project to take advantage of that ability by putting a gradient alpha on my wiggly line layer emitter. Go Hitfilm!

  • Triem23Triem23 Moderator

    I didn't know a layer emitter gave particles the alpha of the source layer either! That opens up a lot of options, like what Norman writes about his gradient. 

Sign in to comment

Leave a Comment