3d model download issue: "invalid package"

Whenever I try to open 3d model file (whether its  .obj .3ds or .Iwo), a window pops up  with the header "invalid package".

Its says that there is no 'package.json' in the package, and that there needs to be one in order for it to work. This also happens whenever i try to download an update for HitFilm.  Please help!

Comments

  • SimonKJonesSimonKJones Moderator

    Hi Bryan - can you clarify whether you're talking about opening a 3D model inside HitFilm, or downloading the model in the first place. I ask because you mentioned it happens when you try to download HitFilm updates, which sounds like this is a general downloading issue.

    What browser are you using?

  • Triem23Triem23 Moderator
    edited May 2015

    Also, maybe try uninstalling and reinstalling Hitfilm? Maybe a file got corrupted on your current install? 

  •  it happens whenever i try to download it, then open it using hitfilm from my firefox downloader extension.

    So, if i uninstall hitfilm, how do i reinstall it? (sorry for all the noob questions)

  • You'll need to try and open the model from within Hitfilm itself, not from the browser.  

  • whenever i try to do it within hitfilm, hitfilm cant seem to find it, no matter what the search options are.  Ive downloaded all the types of files, and even under the "all supported files" option, , i still cant find anything.

    I just used chrome and it downloaded the file, but hitfilm still cant find it.

  • edited May 2015

    still cant fin anything

  • Are the files packed in a .zip or .7z file or something else? If so you need to unpack them first or HitFilm won't see them. If not, could you post screenshots from the folder the models are in, once when open in the explorer where you can see the model, and once when open in the import dialog inside HitFilm when you can't see them?

  • edited May 2015

    From firefox, when you dropdown the list of files you've downloaded, you can either click on the folder icon to the right, or right click on the name and select open containing folder. Either of these will let you know where the file was downloaded to.

    Next, from hitfilm when you want to open the model, navigate to the location you found using the steps above. Note that if the file is zip'd (or someother compression), you'll need to unzip it first.

    Another option is once you've opened the containing folder using the first steps, move it to another folder, such as your hitfilm project folder.

  • edited May 2015

    Are you using the import controls? Click on where it says Import. Sorry if this is obvious but sometimes ...

    Import Box

  • SimonKJonesSimonKJones Moderator

    And to further clarify, when importing 3D models you can't just click the 'Import' button - you need to click the arrow just next to it, and select the 3D model option.

  • edited May 2015

    i think i just didnt know how to unzip files. But now ive gone and uninstalled hitfilm thinking it would be easy to get back....but i cound not find the original start-up file.

    I did a system reboot so that hitfilm could return, but now its not running. i really skrewed things up.

  • i cant repair it or troubleshoot anything, because i dont have the instillation package. So now its just not running anymore.

  • If you deleted the installer you can always redownload it here https://hitfilm.com/account/software by clicking on View Installation Instructions for the software version you have.

  • Triem23Triem23 Moderator

    No problem. Click the "Account" button, top right of this page, and select "Software." From there you can re-download the installer, manage active activations, and see your activation codes. 

  • your not going to believe this, but it says i have no orders, or order history -_-

  • the only downloads associated with my account are the 3d weapon packs.

  • edited May 2015

    ok, i got it! tha ks for the help everyone!

Sign in to comment

Leave a Comment