Quad Warp Position Property

AphAph
edited May 2015 in Express Support

If you manually change the Position properties of Quad Warp (Top Left, Top Right, Bottom Left, Bottom Right) without turning on keyframes, and then save the project, the properties with be reset to "0.0" "0.0" when you later reopen the project.

If you turn on keyframing for this property, it will always add a keyframe at the very beginning of the clip (at the start of frame 1) with Position "0.0" "0.0", or if you had a keyframe already at the beginning of the clip, it will overwrite that keyframe with "0.0" "0.0" when reopening the project. All other keyframes after that seem to be unaffected.

Specs: Win7, Core i7, GT650M gpu, 8g ram

Comments

  • Triem23Triem23 Moderator

    Sounds like you may have found a bug. Out of curiosity is this happening if you parent the corners to points? If not, parent your corners to points and you have a workaround until this is fixed. 

  • Actually, I've only tried it with parenting to points... maybe it works without parenting, I don't know. When you use it with points, the Position property will act as an offset.

  • edited May 2015

    Just had a shot at it and can confirm, that with the four corners attached to points, the corresponding position values will always be reset to 0 when reloading the project, thus not keeping  any offset from the parent points. It does NOT happen though when just using the position values without attaching the corners to layers. I guess this might be an oversight by the developers, as normally you'd set your points up to exactly reflect the desired positions of the corners, including any offset from something else already by rigging several points, as it's just more flexible that way. So that would also be the (slightly more complicated) workaround until this bug is fixed.

  • Triem23Triem23 Moderator

    I admit, I was a bit surprised when Aph said he was offsetting from points. 

    @Aph, may I ask what the shot is? I am not certain why I would be offsetting from a point rather than moving a point directly, and agree with Robin that tge devs likely had the same logic--you may be doing something verrry interesting, there. 

  • edited May 2015

    I used this in my poor mans mesh warp project since I needed a bit of overlap. I just loaded the project, and they've all reset to 0, which wasn't the case when I was working on that project, so this is a recently introduced issue.

  • The project file shows to be 3.0.3813.6, so this issue was introduced sometime after that.

  • AphAph
    edited May 2015

    Triem23  No, nothing real interesting. Using 4 tracked points (tracked from moving objects in a video clip) to slowly scale and move different media shots (video and still shots) around the screen while slightly twisting and turning. Right now just kind of testing. The quad warp is perfect for this, and I just copy the first quad effect (with it's already assigned point layers, etc.) to the other media layers that I crossfade into, etc. For some reason they don't all perfectly line up (most do) and I could tweak the ones that don't with the Position property (without using keyframes) and just leave it... but that gets reset as we now know. 

    Also, on one clip I mask out part of the clip, and I want the mask corners to follow the points not the whole frame of the video, so I use the position property to pull those corners to the quad warp tracked points. In this case, I do use a little keyframing of the position property to keep the masked area from drifting...

  • Triem23Triem23 Moderator

    Nah, I would actually count that as interesting since you're using identical points to synch several layers, and using the offset to strech a masked layer. Clever.

    Instead of the offset, could you create other points and parent them to the main? 

  • "Instead of the offset, could you create other points and parent them to the main? "

    I probably could. Haven't tried it. Thanks for the tip!

    Here's the thing, quad warp Positions DO work even with assigned points, you just have to always turn keyframing on and remember to start at or after frame 2 because frame 1 is always going to have a zero put there by HF3. In other words, you can set up one keyframe for the duration of your clip to get around the fact that without keyframing turned on, HF3 resets the Position property.

    Apparently, this used to work as expected according to rgbii above. And, I sure like things to work as expected! 

     

  • AdyAdy Staff

     Hi Guys,

    Firstly, thanks for your efforts in tracking this down!

    Definitely some odd things going on here, I've raised this issue to a developer this morning so we will hope to get this patched in an update all being well.

    Sorry for the inconvenience caused.

    Ady

  • While they're in that area of the code,  and not to hijack this issue, but.... has anyone found any similar issues with accuracy as I appeared to be having with Quad Points back here, or is it just me?

    http://hitfilm.com/forum/discussion/6477/quad-warp-points-wandering-about-problem-user-error

     

     

Sign in to comment

Leave a Comment