Surpress the alpha channel in a png

Hi guys

Just a quick question. I was doing a little messing about with Vue 2014 complete and hitfilm 3 pro. I was really just testing rendering speed in vue and decided to export an image and try it in hitfilm. I exprted the image as PNG with alpha and imported it into hitfilm. What I found was that hitfilm applied the alpha (hiding the rendered sky). I couldn't find a way to just show the image fully ignoring the alpha. Is this possible or when I start doing this in anger do I need to make sure I export without alpha if I don't want it to be used?

thanks

Comments

  • Triem23Triem23 Moderator

    I think if you right-click the media in the media pool you can turn off the alpha. Otherwise, yeah, export without ot. 

  • Hi @Triem23, I think I tried that but I will try again. It was just me playing around as I said but I'll be using this in the future so I'll check it again

  • I would be highly interested in your results.

  • edited May 2015

    Right clicking on the media lets you set type of alpha, but doesn't have an option to turn it off, which would be nice.

  • Triem23Triem23 Moderator

    It's SUPPOSED to. But this has come up in another user thread where someone was trying to get HF to read the alpha channel in a Quicktime file, and couldn't get the media properties to switch from "None" to "PreMult.". Maybe we've found a bug?

  • edited May 2015

    I agree, it should.

    I checked a few PNG's and a QT animation file with Alpha, all only  showed 'Straight' and 'Premultiplied' as options. A 'None' would be nice. Are you saying someone had a file that was at 'None'  and couldn't be changed.

  • @rgbii yes I remember now. I saw that Alpha drop down and I expected a none option. I can't say I've seen it there before though but it might be a bug

  • Depending on what you want to achieve, you might get away using the following workaround:

    Select 'Straight' as your alpha mode, apply the image/movie to your timeline and add a 'Set Matte' effect on it. Now you only have to set the source layer to a layer that is 100% opaque (you can hide that one afterwards) and the alpha channel of your source footage will be ignored.

  • @OutlineEntertainment - nice work around. It looks like you may not even have to add an opaque layer, just set the 'Matte Source' to be 'Full'.

  • Is the right click only working on png media? I tried it with a clip containing alpha and could not find anything to change. Thanks

  • Nice one @OutlineEntertainment. I'll give that a try with @rgbii tweak 

  • @StephansBilderwelt for me, bringing up the properties by right clicking on the media only shows an alpha option if HF thinks it has Alpha.  So I've had PNG's with and without it, and the same with videos.  So far, it's always shown up on media that I knew had alpha, so if it's not showing up, it may not have one.  If the media is 24 bit, it's probably not going to have an alpha.

  • Okay, thanks. I have tried it now with a picture sequence (png) and found the option for the alpha, that work well for me. 

Sign in to comment