some MP3 files load OK, but other don't load with "file error" message

edited May 2015 in Express Support

I can't figure out where the issue is, as file properties could be identical or  different

any clue? or more detailled MP3 specs

THX in advance

Lupusbalo

Comments

  • Where did you get these MP3 files?

  • AdyAdy Staff

    Hi,

    Firstly as emma24xia asks, where did the files come from? Secondly, are you able to upload one or two of the files that you are having trouble with somewhere so we can take a look at them?

    Thanks,
    Ady

  • Hi Ady!

    I also have this problem (although I don't call it a problem as I can convert the file).

    MP3s I create myself works fine, the files I have problems with, where bought as a digital content.

  • edited May 2015

    @Emma24xia and @Ady: files come from various sources, and I made extensive tests on dozens of files with different sources and settings (kbps, Hz)
    CAN'T FIND ANY CLEAR RULE!! (Though not all but MOST of the ripped files usually work)

    here are 3 files:

    1. ripped from a CD and NOK
      https://www.dropbox.com/s/jo0za7waahw9m06/Ripped from CD (An Irish Moment).mp3?dl=0
    2. downloaded from audionautix.com and NOK
      https://www.dropbox.com/s/xg0kyajf1tdwoyu/Jason Shaw (audionautix) - Banjohop.mp3?dl=0
    3. dowloaded from audionautix.com an OK
      https://www.dropbox.com/s/zx3arfmq9w9qacc/Jason Shaw (Audionautix) - Beginning.mp3?dl=0

    I didn't try any "mp3 repair"

    thanks for your help

    Lupusbalo

    [/edit] I forgot to say that all are well played by several players  [edit/]

  • AdyAdy Staff

    @Lupusbalo - The files you have linked to have multiple ID3 Tags which at the moment in time does not support. Once I removed the multiple ID3 tags the files import correctly & I was able to play them back.

    There are many ID3 tag editors out there, so a quick Google search should yield a few results.

    @Marcin - This is probably the same problem for you, try removing the multiple ID3 tags & see if the files work then.

    This has been logged for the developers to take a look at as an area of improvement but at the moment multiple ID3 tags will result in files not loading correctly. 

  • Thanks @Ady!

    I will give it a try and write results here

  • edited May 2015

    @Ady: Thanks, that's great that you find it, and good news
    (I had considered looking at this, but thought it had nothing to do, so lazily did not go further!!)

    does that mean I should remove all the ID3 tags, or may I keep only 1 scheme (eg ID3V1 only or ID3 V2 UTF16 only or ...) and delete others schemes?

  • AdyAdy Staff

    @Marcin - No problem, please do keep me updated on your progress.

    @Lupusbalo - One should be fine, so either ID3V1 or ID3V2, although when I tested it here I removed them all. You could always make a backup of the files incase you need this information, but having one of the ID3 tags present should mean that they will work.

    Hope this helps. :)

    Ady

  • edited May 2015

    did following tests:

    • remove all tags: load OK
    • leave 1 scheme : eg IDv3 2.4 file error NOK
    • found some files with multiple IDv3 loading OK

    So! by now, the best is to remove completely IDv3  and wait for better times where devs have free time!!!!!!!    (1)

    Lupusbalo

    (1) will not occur soon!!!!!!     (;-{0} 

     

  • @Ady- I just removed the cover picture from the file and now it imports correctly.

    Thanks for pointing the direction!

  • AdyAdy Staff

    @Marcin & @Lupusbalo - Thank you for getting back to me with your results. I'm glad at least that you can now import your files correctly.

    This is an area we would like to improve & your feedback is invaluable to us.

    Thanks,
    Ady

Sign in to comment

Leave a Comment