Hitfilm 3 - Vegas Pro 13 Integration , Hitfilm shifts levels to computer RGB

EdBEdB
edited April 2015 in Express Support

When I add  a Hitfilm 3 effect in Vegas Pro 13 Hitfilm automatically converts the clip from studio RGB  to computer RGB. This problem has been reported before  but  no solution.  How can I eliminate this conversion or provide a choice? 

Comments

  • AdyAdy Staff

    Hi,

    My understanding  is that Vegas uses Studio RGB whereas HitFilm uses Computer RGB (I'm waiting for this to be confirmed by a developer). Vegas does have a Levels effect which can convert from Studio RGB to Computer RGB. But there is no way to change this in HitFilm currently.

    To add the Sony Levels Effect, please click on the Output Video FX button within the Viewer & select the Sony Levels Effect.

    Ady

  • Triem23Triem23 Moderator

    Ady, there should/might be a way to tell Vegas to go to Computer RGB. While not an official white paper or such, this article has useful information on Vegas colorspace. 

    www.glennchan.info/articles/vegas/colorspaces/colorspaces.html

    Vegas defaults to sRGB in 8-bit mode. Understandable is software that defaults to being broadcast compliant. 

    So, you either use the sRGB to cRGB Level preset as needed, or, make your project 32-full range with a gamma of 2.2 and Vegas will stay in cRGB.  

  • ADY & Triem23, thankyou  for your replies.

    If you use the Levels plug-in Vegas Pro 13 with the preset "Computer RGB to Studio RGB" to convert the Hitfilm  to studio RGB the original levels are *not* restored. and there are color shifts clearly visible by eye and on the vector scope.  You can not leave the levels at Computer RGB because Vegas video encoders  expect a studio RBG input not computer RGB. It appears the only option is for Hitfilm 3 to have an option to *not* to covert the clip to computer RGB when in the Vegas integration mode.  

  • edited April 2015

    Which plugins were you seeing the issue with in Vegas, the only ones I could see pushing it out to 0 - 100 were the auto levels ones but adding  levels after brought it back with blending a little of the original back in so it wasn't so aggressive clipping it and you could argue that was behaviour by design I think.  Apart from that the others I looked at seemed to leave the levels alone to me unless I missed something.  Obviously stuff like gleam etc push the levels out but again I seemed to be able to control those with levels and making the effect less aggressive.  I was using 4k mp4 gh4 footage and also tried converting to cinform as well all seemed ok.

    It does still clip it if you have a mp4 track in hitfilm it assumes its 16-235 and expands it out to 0-100 regardless and clips it and if you open the hitfilm file in Vegas you can't fix it with levels as it's coming in clipped but you can get around that by rendering out to ciniform or dnxhd and HF leaves the levels alone, especially now the restrictions of rendering to 4k ciniform appear to have been lifted and ciniform works in hf3 as well that's quite nice to use for both.  It clipped like that in HF2 as well.

    Also about vegas expecting studio levels, in my experience with the GH camera series and MP4 / MOV vegas just doesn't try and guess what levels you are giving it and leaves them alone if i give it MP4 recorded at 16 - 235  studio levels the luminance looks to be 16 - 235 in scopes in vegas if I give it full range the luminance looks to be 0 - 255 in scopes vegas and I can adjust either as I like.  I always thought that was one of the benefits of vegas that it left it up to you how to manage the levels and how you wanted to see them.

  • Aladdin4dAladdin4d Moderator

    @EdB I actually think Triem was talking about setting Vegas up before doing anything in Hitfilm. Setting the project properties to 32 bit float full range and compositing gamma to 1.000 converts the corrected gamma values to linear light values for optically correct, higher quality compositing. I think this should match what HitFilm does. As far as I know all compositers match this behavior internally with any correction being done post compositing. I know After Effects works this way with Adobe's color management providing correction as needed based on the working space profile selected.

    The linear light values can wreak havoc with some of the Sony VFX plugins (many others work much better!) most notably here would be the Studio RGB to Computer RGB preset which no longer does what it says because it expects to be working with gamma corrected values. Setting the compositing gamma to 2.222 gives you the corrected gamma values and the Studio RGB to Computer RGB preset works as expected but you lose optically correct compositing. You can get optically correct compositing in a 2.222 project by nesting or embedding a 1.000 project in a 2.222 project. Just like in HitFilm the embedded project will be processed baking in the 1.000 linear compositing. 

    "because Vegas video encoders  expect a studio RBG input not computer RGB."

    If only things were this simple! Many of the Vegas decoders and encoders change default behavior based on the project settings while others remain the same regardless of the project settings and others still that can decode to cRGB because that's how the footage was captured while expecting sRGB for encoding because of the project settings! HDV, Mpeg 2 and Sony YUV change depending on the project settings and the MP4 variants can and will decode to cRGB if the footage is full range even in a limited project just like @mark_e described. The page(s) @Triem23 linked to have a matrix detailing how some third party codecs and the Vegas codecs behave under the different project settings. If you haven't dug all the way through those pages yet they are loaded with information you can use.

    Now that's just the Vegas stuff! How HitFilm behaves can be affected by what codec the footage is using which @mark_e also mentioned. If you convert your footage to an intermediate that always decodes to sRGB like CineForm or DNxHD then HitFilm will process it "as is". 

    So I guess the moral of the story is you can go with an intermediate that always decodes to video levels or you can try embedding a 32 bit full range linear Vegas project with an embedded HitFilm effect in another Vegas 32 bit video levels project and see what happens.

  • @EdB - Not sure if this will solve your proble, but  I had similar issues with my Canon 7D/70D files between HF and Vegas.  My workflow now includes converting all my Canon footage to DNxHD, which among other things, solved the problem since both HF and Vegas seem to treat it's color/contrast the same. 

  • I convert all my camera(s) footage to Cineform (mov wrapper) using GoPro Studio Premium (latest level). All the results I reported were determined using the Cineform files. 

  • edited April 2015

    i rendered my clips out to avi via Vegas to avi as ciniform, I wonder if it's because of the mov wrapper, im def not seeing the shift doing it like that, have you got a sample clip you can chuck in Dropbox or whatever I don't mind quickly seeing if I can reproduce, will help HF team figure it out if it's on multiple systems. 

    Edit: scrub that i'd have to put QuickTime back on and I don't want to do that, but I'm sure someone will double check :)

  • - Run this simple test and see what results you get.

    - Launch Vegas Pro 13 and select the color correction layout

    - Project is HD 1080-60i (1920x1080,29.97 fps)

    - Add an intermediate HD clip to the timeline (same specs as project) with   preferably the same image across the clip. 

    - Move the cursor to the center of the clip and right click to select add Hitfilm effect

    - Watch the scopes - Histogram...  the video levels will switch from studio RGB to computer RGB.

  • I don't see it I've not used interlaced for years if it's something to do with that and I'm in the UK so tend to run 25p

    Here's 2 test files 1080p 25fps to try and make things a little more scientific ones a gradient 0-100 ones a gradient 16-235 both avi ciniform.

    Both of those if I create a hifilm project, save it and open it in vegas come across fine the levels are the same as if I opened then in vegas direct.

    I add hitfilm vibrance to them as a hitfilm project opened in vegas the levels do not jump for either.  Other plugins obviously can push the ranges because of what they are but can be controlled by levels in vegas from what I can see.

    Could you post an example of something that does not work for you to save having to guess.

    https://www.dropbox.com/s/6n1ij7ddv9zu62g/16-235-grad.avi?dl=0

    https://www.dropbox.com/s/0gwlp9p6a28dkd5/0-100-gradient.avi?dl=0

    BTW I'm not saying there is no issue, I think the clipping of the .mp4 wrapped codecs is a bug that has persisted since HF2 but the workaround of re-encoding it worked for me.

  • EdBEdB
    edited April 2015

    I have not been able to come up with a 'reasonable  size' test case that demonstrates the problem. The following screen captures show the video before and after the transfer from Vegas to Hitfilm. You can see what is happening on the scopes.

    Links deleted

     

  • EdBEdB
    edited April 2015

    I have found a solution. If I convert the mts  files to Cineform  in  Vegas the there is NO shift in video levels when I select add Hitfilm effect.  This should help Hitfilm and SCS solve the problem.

  • Aladdin4dAladdin4d Moderator

    @EdB Glad to hear you found a solution! I was going to mention that I noticed there's now an option in the Cineform configuration options to allow full range RGB decoding and was going to suggest making sure that was disabled and trying again.

  • EdBEdB
    edited April 2015

    @Aladdin4d I was using GoPro Studio Premium (latest Version) but I could not find an option to set/change encoding format (RGB, YUV). Then I found the options  in the Vegas Pro  Quicktime 7 mov encoder and created a Cineform template  Video Format YUV 4:2:2 and  that  solved the problem. Using the Vegas Computer RGB to Studio RGB Fx  to correct the problem is poor at best..

    Many thanks for help and suggestions.

Sign in to comment

Leave a Comment