HitFilm Pro 3 major stability issues

edited April 2015 in Pro Support

Ive been playing around more and more with HF3 and finding it more and more buggy. It keeps on crashing at random intervals. I have suspicion it has to do with the new update. Didn't do this before. Whenever software has so many updates coming out in a short space of time, something usually goes haywire in windows internal wiring of things. Just now I was busy with a project, probably 20 - 30mins of work without saving, and all I did was switch unsharpen mask, which was in a grade layer on a single 10sc clip on and off to see the effect and HF decided to crash and send an error report to main server or something. It wasnt even an intensive effect and I had set my viewer to half resolution. Its really worrying. And this is just is probably the 10th issue I have encoutered in the past two days alone of playing with the software that made it crash..

Comments

  • edited April 2015

    Thats not my experience. I find HF3 to be very stable, I use it for hours at a time with no problems. What are your computer specs and are your video card drivers up to date?

  • Since I installed HF3 I have actually had to roll back on my video drivers.. I would get a system wide crash upon startup.. I have 16GIG's of RAM and a super fast graphics and intel processor.. cant be that.. I had HF which ran really well and fast as hell, but ever since HF3 came out. its been slow and very buggy! Ive had nothing but problems

  • If I had been using HF, doesnt matter for how long. After I finish and I want to shut down my PC, I always get an error message that pops up as my pc is trying to shut down, saying the Hitfilm server has crashed, this is after exiting the program.. ???

  • Huh, none of that happens for me. I just used it last night for hours and didnt have any crashes. You should open a support ticket.

  •  Hi EricZodiac

    I have had many issues with the new version of hitfilm, mostly with up to date drivers, Are you using ATi or Nvidia ?

    from windows 7 to 8/ 8.1 and even 10, i repeated the process with a project and found that masking was a big issue, the masks would break up and flicker merging frames making them white then blank and then separately flashing individual composite shots, 

    applying atomic particles to models crashed the program instantly on any model.

    and there has been many other issues, for now the best thing to do is stick to back dated drivers, give the developers some time to fix the bugs they are doing a good job as it is :)

    also on a side note, on windows 10 its smooth, quick and works very well with things that doesn't crash it. 

  • ..Too date the technical preview is fbl_impressive 10049 Professional

  • @EricZodiac - what is your graphics card? Having to roll back to older drivers is an odd thing to have to do, as we always recommend using the latest drivers.

    You also indicated in your first post that you often have stability issues with software that updates regularly. This really shouldn't be the case, so some details on your computer spec would be useful. If you're having stability issues with other software as well there may be a deeper problem.

  • Hi, we're having lots of problems to with Hitfilm3. Working on an intensive Project, we encountered at least above 25 crashed in the last 2 Days. Also RAM preview is not helping, as it gets slow with bigger Projects. Realtime play is nowhere near in sight in HF3, so we can't actually do precise movements with Keyframes at the present time. There are constant crashed, when entering a composite, which has been started to render to proxy. Sometimes Proxies can't be cancalled without crash. And lots of other random crashes. Proxies can't be played in realtime too, and we don't have realtime in quarter resolution. HF2 had the same performance problems. Our Project is in UHD.  Hitfilm is the only Program on this Computer, that crashes.

    System: i5 2.8GHz, 12GB Ram, GF GTX 580, Win7 64bit.

    Is there a need for a higher Graphic Card...maybe a GTX 980? Or do we need more ram? Or a SSD for the proxies? They only play with 1 Picture per second currently in HitFIlm.

  • @Batty I have a GTX 980 and I still have issues with Hitfilm so the graphics card will not be a magic fix although it helps. I have an i7, 18gb ram, and the GTX 980 and I have crashes, slow start times for new projects, etc. Proxies have always been an issue for me. I hope that helps so you don't spend a couple hundred dollars to only have to start I new post :) that it didn't work. I hope you have a great day. 

  • edited June 2015

    @Batty your system sounds fine from the bare specs. I had a 560ti and it worked not fast, but flawlessly, so yours should be good (as long as the gpu drivers are up to date - are they?). Also Proxies should play near real time when played on their own (definitely not 1fps), even with your gpu. An SSD might help, but I'd let one from the team confirm that.

  • Batty
    Are you using image sequences? High res image sequences seems to affect performance of HF even when using proxies. Proxies are no where near as real time as the previewer so I prefer to use that. Too bad the previewer seems to be reaching its limits with your comp, too.

  • Thanks for the help everybody :).

    And yes, graphics drivers are up to date. I mostly use Material produced inside Hitfilm3 (Stars made outta flares and particles with FX on them, some color planes for Keying and masks) a 3D object (3DS formatted) and a few pictures in 4K resolution, some with green keying backgrounds and those are keyframe animated, that's a about it. But it involves heavy cascading of compositions.

    It sounds like a new SSD would make the most out of Hitfilm for me I guess :p?

  • edited July 2015

    Hitfilm 3 won't start up. I initiate the program but it never opens. I'm using a Mac. I am current  to your recent update.

     

  • NullUnit, if you don't mind me asking what operating system are you usuing ?

  • AdyAdy Staff

    HitFilmer196290 - This thread is a year old, if you are having issues with the software please contact support here.

    Or if you wish to ask NullUnit a question, please send him a private message.

    Thanks,
    Ady

This discussion has been closed.