14 hour export peaking at 2% CPU

I have a 9 minute long chroma-keyed and color-corrected clip currently exporting (1080p 60fps H.264). It says it's gonna take about 14 more hours. When I take a look at task manager, it says that HitFilm is only using a max. of 2% CPU (and FXMediaQTServer is peaking around 3%, but I'm not quite sure what that does).

My computer specs are quite nice, with an i7 extreme, 32GB of RAM, and an NVIDIA 780. I don't know if HitFilm is set to use my GPU (which I've heard it should), but I also don't know how to set it it to use my GPU. Could this be the issue? Or is it really supposed to take this long to export?

Comments

  • Hitfilm mostly uses the GPU for rendering rather than the CPU.

    Is you system a dual GPU system?

    If not, it should already be using the 780, but if it's a dual GPU (mostly seen in laptops), then you probably do need to tell the system to use it.

    I know on my system, I can right click on the desktop, then click on NVIDIA Control Panel.  For me, I select 'Manage 3D settings', then click the 'Program Settings' Tab. From there you can select/add Hitfilm and it's other executables and make sure they are using the better GPU.

     

  • i7 EE (something about 5820k or 5930k?) can't be found on laptop so I think you got a desktop computer.

    Do you try to execute the export or just look at the forecast at the beginning of it? Because forecasts change over time. 

    Also what about gpu activity?

  • HitFilm does use your gpu without you having to tell it. Actually, you can't tell it NOT to use the gpu. As @rgbii stated, it might accidentally use the gpu chip integrated in your i7 though, so check that. Do you have a gpu monitoring program? With this you can easily check if HitFilm is using the cpu. Also, you're only reporting the cpu usage of 2 single processes, what about the overall cpu usage?

  • As been mentioned before. Encoding or exporting is done on cpu not gpu.

    Gpu is used to preprocess frames but if the video has no fx in it hf will still use the gpu anyway which makes it slow. It shouldn't use gpu if there's no fx that was applied.

    http://hitfilm.com/forum/discussion/comment/51632/#Comment_51632

    Take note of Hendo's comments. HF has a unique way of preprocessing on gpu then encoding on cpu which makes it really slow for encoding video.

  • edited March 2015

    Just for note: i7 Extreme Edition doesn't have any integrated GPU.

    Suggest to use something such as Gpu-Z monitoring program to check your 780 GPU activity.

  • SimonKJonesSimonKJones Moderator
    edited March 2015

    Can we get a bit more info on the project? That render time seems pretty long based on your description, but there might be elements we're overlooking. It is worth mentioning that the render estimate is just that - an estimate. It updates every frame based on what's going on, so can sometimes throw out a really broad estimate and then complete far faster.

    What source media are you using? Both in terms of the media you're keying and any media you're using for the new background etc. You mention colour correction - what specific effects have you used?

    Thanks!

  • Thanks for all the replies, guys. I'll try to address everything mentioned.

    It's been exporting for 12:45 now and estimates about 2 hours left.

    @rgbii & @davide445 & @robin I am on a laptop. It's a 780m. I went to the NVIDIA control panel and found what you were talking about, but HitFilm was not listed in the programs. I don't have any applications to report GPU usage, and the processes that I mentioned were the only ones that seemed to be from HitFilm.  I do think HitFilm is defaulting to the integrated GPU on the processor because I believe programs have done that before. I went ahead and set the global settings to always use the 780. My total CPU usage was peaking around 5% (with the extra 1% likely being used by Firefox and some system processes).

    @SimonKJones The keyed media is just a dude being interviewed in front of a greenscreen. 1080p, 60fps, ~9 mins long. I used the green-screen key preset and tweaked some params, along with light spill. The background is a hi-res image that I applied the lens blur effect to (default params) and enlarged. On the keyed layer, there are: CC wheels, contrast (don't remember specific effect and can't check cause exporting), and saturation. There are no 3D effects or layers, which is why I'm surprised it's taking so long. On a side note, I love your video tutorials. They're really helpful. :)

  • @CepheidMedia while you can set it to always use the 780m for everything, I find it much better to set it for just the programs that need it. Always using the 780m will drain your battery faster and make your laptop run hotter.

    Hitfilm probably won't use the 780m until you exit and reenter it since it started on the slower GPU and I don't think it can change while actually running.

  • Triem23Triem23 Moderator

    Side note: if you have the drive space to spare, rendering PNG sequences is way, way, way faster than rendering to any video codec. Pc doesn't have to hold a video file constantly open so that frees resources. Since you are rendering stills you can abort a render and resume from the last frame you were at instead of from the beginning. Also, you get lossless video at half the size of uncompressed AVI. Yes, there's now the extra step of re-importing your image sequence to re-render your final output, but the speed increase and flexibility of rendering the PNG sequence makes it well worth the extra step. 

  • @Triem23 Wow I never thought of that. How does that affect the quality of the final product?

  • Triem23Triem23 Moderator

    It's uncompressed quality. As good as 8-bit gets. PNG is lossless, which is why it only cuts filesize to about half of uncompressed AVI. JPEG is lossy, but can compress about 10—20:1 pretty well. 

    By contrast, uncompressed 1280*720 @24fps video is over half a million megabits-per-second (518.4) so compressing that to Hitfilm's default 10mbps is an over 50:1 compression with DNxHD 145 being about 3.5:1.

  • CepheidMedia "The background is a hi-res image that I applied the lens blur effect to (default params) and enlarged."

    Side note, (and apologies if you are already doing it this way) is if you are resizing and blurring a static background image every frame, that will eat up cpu cycles.   Best to save it out as a new image with the affect applied and use the updated version as the background to avoid re-inventing the wheel every frame.   Even if you are slowly scaling the image (as a camera move or zoom effect) its still faster to pre-blur.  

  • edited March 2015

    So here's the thing... I just started exporting again after restarting HitFilm. Same everything, except I changed the H.264 level from 5 to 4.2.. It now estimates 2 hours total. I'm not sure if it was because of the GPU switch or the level switch (or both), but I think that did the trick. Thanks for everything, guys.

    Edit: It's also using a ton more CPU (15%) and way less RAM (half a Gig, rather than a whole Gig). Go figure.

  • Since it's rendering each frame faster with the better GPU, everything else is going to move along faster too, such as encoding, which uses CPU.  While the level might make a slight difference, I'm betting it's faster mostly due to the GPU.

Sign in to comment

Leave a Comment