REDGIANT Universe & Hitfilm 3 Pro

I have followed another discussion on this issue and have attempted all suggested things.  BUT I CAN STILL NOT VIEW THE REDGIANT UNIVERSE PLUGINS IN HITFILM OR USE THEM!!! PLEEAASE HEELP!! I heard something about letting redgiant univers detecting the software...

Is it a problem if HF3 Pro is in Program files and Redgiant is in Program files(x86) both on (C:)

Comments

  • If they're both installed on the same drive, it should work. Make sure you have the most up-to-date version of Red Giant Link. (https://www.redgiant.com/store/universe/) The download button will appear after you sign in.

    If this still does not work, I'd recommend opening a support ticket with Red Giant on their website or creating a forum post.

    Good luck!

  • I've already tried that but thanks for trying to help :)

    I am going to try uninstalling Universe in redgiant link and re-downloading!

    I hope it works...

  • I've got same problem here. After upgrading my PC, without Windows 8.1 reinstaling, Redgiant universe stops showing in HitFilm 3. Reinstalation of RedGiant doesn't help. Anyone know the solution?

    And my sugestion. When opening my project with RG Universe used in, Hitfilm shows a message, that some plugins can't be located - there should be some info about plugins names.

  • edited June 2015

    Ok I've got it. I need to deactivate the HitFilm and then activate it again and RG Universe starts working properly.

  • edited July 2015

    Cool.

    The other thing is I am assuming from looking at my hard drive that red giant make universe in a 64 bit format (given that it shows on my windows machine under "Program Files" not "Program Files (x86)" ). That would indicate that it is available in 64 bit. Given that Hitfilm is 64bit, you should have no need or use for Red Giant Universe 32 bit.

    I've had no issues whatsoever with Red Giant Universe showing up in Hitfilm, and maybe I am just lucky.

Sign in to comment

Leave a Comment