Is the H.264 "High" Profile supposed to export progressive media as interlaced?

edited January 2015 in Express Support

Is the H.264 "High" Profile supposed to export progressive media as interlaced?

Don’t understand this well enough to be sure this is a problem, but it took some time for me to figure out how TF I ended up editing an interlaced video in Sony Movie Studio 13 that came from an HF3P ("High" profile) export.

Thanks.
Jeff

Comments

  • Triem23Triem23 Moderator

    H.264 isn't supposed to render interlaced. Heck, Hitfilm doesn't do interlaced at all! Is your export from Hitfilm 100% CG elements (particles, text, images from stills?) or was there source video in the Hitfilm project? I am wonder if you took interlaced video into Hitfilm to begin with and "baked in" the interlace combing. 

  •  Original video straight from a Canon T2i.  It's trivial to reproduce on my system.

    Issue summary:

    Canon T2i video file recorded in 29.970 fps progressive, 1920x1080 exports as 29.970 fps progressive, 1920x1080 in “Main” Profile.  When profile is changed to “High” the export shows as 29.970 fps interlaced, 1920x1080.

    To reproduce:

    1. Create New project.

    2. Set Project Settings to 1080p Full HD @ NTSC 29.97 fps, Square Pixels

    3. Hit “Start Editing” button.

    4. Import 29.970 fps progressive, 1920x1080 video

    5. Move video to Editor time-line

    6. Export H.264 with settings:      1920x1080      Keep Aspect Ratio      Frame 29.97      AR 1.0      Profile: MAIN      Level 4.0, VBR1P      TBR: 10MBPS      MBR: 15MBPS

    This produces an MP4 file that Sony Movie Studio reports as:

    29.970 fps progressive, 1920x1080x12, AVC

     7. Change Profile to High. Now the export produces an MP4 file that Sony Movie Studio reports as:

    29.970 fps interlaced, 1920x1080x12, AVC

    Meta-data problem maybe?

     

    System info:

    HF3P, Windows 7, i7-4790s CPU, Radeon R9 270x GPU, 16g System RAM

  • Triem23Triem23 Moderator

    Maybe--that shouldn't be happening. Possible bug?

  • JeffFoster - Could you upload the original footage you used for me to test it here? It doesn't need to be the whole footage just a sample is enough.

    I would like to take a look at this ASAP.

    Thanks,
    Ady

  • Ady, I messaged you a link to a zip file with all the files, including screenshots of the Sony MS13 property screen showing "Interlace" format of the High profile export.  BTW,  I repeated the test in HF2XP and it does the same thing.

    Jeff

  • I know the advanced HEVC/H.265 is available for some camcorders, but not sure if HitFilm can support the new codec as input file.

  • Triem23Triem23 Moderator

    Hitfilm does not currently support h.265. As of November, 2014, NO NLE supports h.265. I don't know if this has changed for anyone in the last two months.

  • JeffFoster

    Thank you for uploading the footage, I have conducted some tests here & can confirm that if you use the Profile: High & Level at either 4.0 or 4.1, Vegas does interpret the footage as being Interlaced. If you increase the Level above 4.1 it interprets it as Progressive.

    I have logged this for the developers to look at, it will be tomorrow at the earliest before I have any further information about this. I am unable to confirm whether this functionality is correct.

    Sorry for any inconvenience caused.

    Thanks,
    Ady

  • Triem23Triem23 Moderator

    Is it possible that particular codec configuration is reserved for broadcast mastering in h.264? Broadcast is still interlaced. 

  • @Triem23

    That is entirely possible, unfortunately I don't know know enough about it to be 100% certain so I have asked for clarification. I'll update the thread when I have an answer.

  • Triem23Triem23 Moderator

    I did a little research, and while High Profile h.264 supports interlaced encode/decode there's nothing in the spec about interlaced being a DEFAULT setting on any profile, so that's probably not it, but a flag may defaulting incorrectly in the renderer. I dunno. I ain't a coder. ;-)

  • Thanks for the diligence.

    Jeff

  • Has the footage actually been split into fields, or is Vegas simply misinterpreting it? If it's the latter, you should be able to go into the media's properties inside Vegas and simply switch it manually to progressive.

  • This looks like a problem with Movie Studio / Vegas misinterpreting the video stream.

    MediaInfo, mocha, Premiere, and HitFilm itself all import the High-profile H.264 mp4 exported by HitFilm as progressive.

Sign in to comment

Leave a Comment