Masking not working even with up to date drivers

Masking tool removes the entire layer for me still, even with current Nvidia drivers 347.25. Is anyone else still having issues? If not what drivers are you using? I even tried rolling back a few drivers as well to no avail.

 

Comments

  • Hi,

    Sorry you are having issues with the software, could you maybe detail your system specs to me below:

    OS:
    CPU:
    MEMORY:
    GPU:

    Thanks,
    Ady

  • Thank you for the quick reply Ady,

    I am running:

    OS: Win7 64
    CPU: i7-3770k
    MEMORY:16gb
    GPU: gtx-680

    Thank you,

    Nate

  • Hi,

    No problem, could you upload a simple project using Planes that has the masking problem present. Maybe attaching a screenshot too so I can see what you are seeing?

    Then I can load it here to see if the problem persists?

    Many Thanks,
    Ady

  • Thank you Ady,

    I have attached and Image where I have overlayed a black layer on top of some footage. I then applied a ellipse mask to the black layer and immediately everything outside of the mask disappeared. I then switched the mask to "subtract" and now the whole layer is gone.

    hitfilm masking issue

     

  • Triem23Triem23 Moderator

    I have encountered this same issue as well.

    Workaround: create a mask earlier in the chain. Make sure it covers the whole layer, and set to ADD. 

    Once you set a mask to ADD mode, you can use a second mask to SUBTRACT the hole.

    @Ady it's like the layer mask has a "Boolean" logic, where you have to define a base area with an ADD mask first, rather than being able to "Invert" an add to subtract like reversing a Set Matte. Is this the intended behavior? 

  • In terms of this specific use case, the easiest thing to do is add the initial mask shape, then just invert it, and you're done.

    The logic thing Triem is talking about is something we'll ponder.

  • Instead of setting the mask to subtract, set it to Add, and Invert it, and you should be good to go.

  • Thank you everyone I will give it a shot. Where is the option to invert the mask?

  • Its the very first control, at the top of the Mask controls. Its says "Inverted" and has a tickbox. Tick the box to invert it.

Sign in to comment

Leave a Comment