Problems with speeding up clips

I'm making a video that involves a lot of clips that need to be sped up. When I apply a speed effect to my clips, the clip is sped up, but the size of the clip stays the same.  This leaves a black section of video in my clip.  I can't trim the black part out, it will only trim the regular section of the video.  Does anyone know what I can do to get rid of this black section of video?

Comments

  • I'm making a video that involves a lot of clips that need to be sped up. When I apply a speed effect to my clips, the clip is sped up, but the size of the clip stays the same.  This leaves a black section of video in my clip.  I can't trim the black part out, it will only trim the regular section of the video.  Does anyone know what I can do to get rid of this black section of video?


    Adjust the length of the composite shot you are working within (where you applied the speed effect) to the point where the clip ends (this is the properties tab near the top right of the composite timeline).  You could also adjust the size of the actual clip from the editor window to also match the length of the new sped up clip. 
    Hope that helps!
     


  • Adjust the length of the composite shot you are working within (where you applied the speed effect) to the point where the clip ends (this is the properties tab near the top right of the composite timeline).  You could also adjust the size of the actual clip from the editor window to also match the length of the new sped up clip. 
    Hope that helps!
     


    The problem with a composite shot is that I have a lot of clips I need to speed up for this video.  It would be a real hassle to have to make each one a composite shot, adjust it, export it, then import it, for every shot.
    Unless I'm doing it wrong, adjusting the size of the actual clip in the editor window doesn't work.  It only trims the video and leaves the black part of the clip.


  • The problem with a composite shot is that I have a lot of clips I need to speed up for this video.  It would be a real hassle to have to make each one a composite shot, adjust it, export it, then import it, for every shot.
    Unless I'm doing it wrong, adjusting the size of the actual clip in the editor window doesn't work.  It only trims the video and leaves the black part of the clip.


    I'm trying to picture how you have this setup, can you get a screenshot of the entire window - where you added the speed effect to and where your clips are placed?
    If you make a clip a composite shot in HitFilm, you don't have to export it and re-import it... it's linked to the timeline of the editor so all you'd have to do is adjust the length of the "editor" clip, if the changes were made in the composite properties tab. 
    Are all your shots being adjust to the same speed? 
    If they are, you could add a clip to the timeline - make it a composite - adjust the properties of that composite to the length of all your clips combined - add all other clips and arrange them all in chronological ordering for how you want your video to playout.
    Once everything is within that composite shot - select ALL your clips that are currently within the original composite shot - make those all now into another composite shot.
    Go back to the original composite that now contains a composite of all your clips and apply the speed effect to that composite.  All of the clips should now be sped up to that amount.
     

  • I was unsure what you wanted a screenshot of, is this good?  
    [attachment=835:Capture.PNG]
    I tried making a short video instead of a screenshot, but when I tried exporting that video out of HitFilm, it said "1 hour 19 minutes remaining" for WAY longer tan an hour and nineteen minutes, then it said the export failed.
    I'm not going to speed up all my clips to the same speed, so what you said about that didn't help.
    Also I didn't understand this: 
    If you make a clip a composite shot in HitFilm, you don't have to export it and re-import it... it's linked to the timeline of the editor so all you'd have to do is adjust the length of the "editor" clip, if the changes were made in the composite properties tab. 

    And when I apply the speed effect to a composite shot, I still get the black at the end, even when I try to cut the black part out.


  • edited February 2014
    I was unsure what you wanted a screenshot of, is this good?  
    attachicon.gifCapture.PNG
    I tried making a short video instead of a screenshot, but when I tried exporting that video out of HitFilm, it said "1 hour 19 minutes remaining" for WAY longer tan an hour and nineteen minutes, then it said the export failed.
    I'm not going to speed up all my clips to the same speed, so what you said about that didn't help.
    Also I didn't understand this: 
    And when I apply the speed effect to a composite shot, I still get the black at the end, even when I try to cut the black part out.


    Ah okay that gives me a better idea of whats going on.
    Unfortunately, I'm not near a computer with HitFilm at the moment, so I'm relying on memory for this.
    It appears you are directly applying the speed effect to a clip within the editor window.
    Take the clip in question (on the editor timeline), take off the speed effect, right click the clip and choose the "make a composite shot".  This should open you up into the compositing window for that particular clip (image below).  From here go to your effects and drag the speed effect over to the layer in the compositing window.  Input / select the value at which you want to speed the clip up by. 
    composite%20shot%20intro.zoom40.png
    So now, if the clip was 4s long and you sped it up by 2 it should be 2s long, however the entire size of the original clip is still the same as it was before (blue highlighted bar).  Scroll to the point at which the clip ends (2s mark) make note of the time and adjust the properties of the composite to that time.
    Click back to your editor window (top left of compositing window) - click on the clip - it should show the "original clip size" highlighted in solid blue (2s worth) and the other part "broken up diagonal bars" indicating there is no clip available there since the composite file is only 2s long.  Now adjust the size of the clip on the editor window down to the appropriate length.  If you play the now adjusted clip from the editor window it should only play the sped up portion of the your clip or the above examples, 2s worth of clip. 
    This last part is what I meant about the composite shot (of your clip on the editor window) is linked between both the editor window and the compositing window therefore you don't need to export the video from the compositing window and re-import it back into HitFilm and place it back on the editor window.


  • edited February 2014
    Okay, just checked it out on HitFilm.  Some of the above doesn't appear to work as is.  There appears to be a glitch with the speed up effect. 
    However, the following does work:
    Add your media to the editor window
    3ceb3861-7b6b-4358-9bfd-0e989cd8ad89_zps
    Right click the media clip - and create a new composite
    bf080f25-a9e2-4ee8-afcd-124e383df909_zps
    Apply the speed effect and adjust value.  After that find where the clip now ends as a result of the speed change (1:18 for me)
    81517a2f-38f7-4af8-aeff-d0fca25c1fb1_zps
    Go back to the editor window and find the exact same time (1:18)
    530b0d74-574f-42db-b2c9-be3f4cff70f8_zps
    Clip the excess clip or shorten it to the above mark.
    47a83fc5-33b1-49d8-9db1-4dd9172907ba_zps
    Let me know if that resolves the issues for you.
    Also, if you adjust the properties of the composite shot to the time that your clip ends in the above example 1:18s it'll show the below picture in the editor window so you know exactly where to clip it :)
    0814e2d8-4fbc-449a-ad5b-2014cbb04d79_zps
  • I got it working, thanks for the help!
    Following your instructions exactly didn't work, but I figured out that if I skipped this step:
    Scroll to the point at which the clip ends (2s mark) and cut ( C ) the clip at that point (delete the rest)

    it did work!
    Thank you so much!  :D 


  • Somehow I missed this post: http://community.hitfilm.com/index.php?/topic/4907-problems-with-speeding-up-clips/#entry39331 and didn't see it until I already figured it out.  
    Sorry about that.
  • edited February 2014
    You've just saved my life.. thank you.
  • edited March 2014
    thanks a lot for this simple "tutorial" :D
    should be a short vid tutorial for this..
    and 1 question - why I can not use "ripple delete" or "ripple delete gap"?
  • thanks a lot for this simple "tutorial" :D
    should be a short vid tutorial for this..
    and 1 question - why I can not use "ripple delete" or "ripple delete gap"?


    Where are you trying to use the ripple delete gap?  Is it at the part where you know the composite shot doesn't contain anymore footage and you want to automatically delete that section?  (The angle lines area?)

  • edited March 2014
    First sorry for my english ;)
    It's a pity (? :P) that I had already finished project and I did not think about making some screen shots ;/
    I will use old project (by default no speeding).
    I will show You what I'am doing step by step:
    1)I add everything on timeline ("editor" bookmark) and cut out "Audio 1" with sound from clips
    2) converting clips to composite shots
    12925188905_f1ab7c839f_o.jpg
    3)I add "speed" to clip. I understand that I also must set "out" point when clip ends
    12925302903_7338c08635_o.jpg
    Now I have problem - I can't ripple delete black clip nor clip with content (here - part of movie)
    12925605894_6b278eb139_o.jpg
    4)I can only delete them and move rest of clips only manualy :(
    12925606734_d44d116107_o.jpg
    Also, whene I create composite shot from video clip program recovers it's old soundtrack - and! paste this in new Audio timeline for each composite shot which I have made.
    Sometimes, there appeared possibility to use " ripple delete" or "ripple delete gap" - that was confusing :P
    What am I doing wrong? For me that was very iritating work ;/

    BTW there could be a separate, compressed window for all this composite shots (like i.e. this one with layers in Photoshop -small, simple, fast to use). Using 'bookmarks' or project media is very hard when i try to work with over a dozen clips :P
  • You can only use the Ripple Delete or Ripple Delete Gap when there is a gap on the timeline.  In the example you show, there is still media on your Audio track, so you can ripple delete.  The Ripple Delete options apply when there is a gap on every track of the timeline.
  • It appears Axel beat me to it!
    In your example the audio layer on "audio 2" that you're trying to delete the ripple gap.  It's still linked to the above media, which is not able to move due to the media layer infront of it (unlink it by clicking on that infinity symbol).
    To add to what Axel said, my suggestion would be since you're doing speed effects, focus on editing your timeline with those in place first before adding in your audio layer (music instrumental layer).
  • [SOLUTION]

    I know I am late for this post, but I found the problem.

    When you right click and go in "speed/duration". There is a little (verry little) icon at the right, you need to click it lol

    I think the video got unlinked or something (maybe by deleting audio but honnestly I dont know.)

  • I'm having a similar issue to the above users, I've tried the fixes described here but have been unsuccessful thus far.

    I have a clip that is sped up (300%) which I wish to make a composite shot to add text on top of the video, this has worked fine for all non-sped up clips. However, when I make a composite shot it doesn't match the timing of the video, it seemingly plays the first 4 seconds of the original clip rather than the sped up version for 4 seconds meaning I am left with a black screen for the remainder of that particular clip.

     

    Hope someone can help me, thanks.

  • edited September 4

    EDIT: Scratch what I originally wrote here.  I didn't test it thoroughly.  Making a comp out of a rate-stretched clip doesn't behave as (I believe) it should.  HitFilm sees the length of the rate-stretched footage, adds that shorter length to the comp, then rate-stretches the comp on top of that.  

    To get what you want, set your clip back to 100% playback speed.  Make a comp out of it, then rate-stretch that comp on the editor timeline.

  • I'm going to start a new thread in the Express Support forum to report the issue re: making comps from rate-stretched footage, as I believe the current behavior is a bug.

Sign in to comment