Red Giant Universe + HitFilm Pro 6 + OSX High Sierra does not work anymore...

Hi Folk,

since the update to High Sierra and Hitfilm Pro 6 the Red Giant plugins does not work anymore. If i want to install Universe the installer can´t find any host application. The compatibility check on https://www.redgiant.com/support/compatibility/host-applications/ the combination of Universe 2.0 or 2.1, Hitfilm and OSX10.13 says that its not longer compatible. Is this truth ? Is there any bugfix or workaround ?

 

Hopefully,

Marcel

Comments

  • I have a similar problem with a Windows install - I just purchased the Universe plugin subscription collection and its not showing up in Hitfilm Pro.  Any help be appreciated - 

    Cheers

    Saul

  • edited December 6

    Maybe Red Giant hasn't updated its installers and website to add the new HitFilm Pro yet, it is still very new. You should probably contact Red Giant directly to ask if they intend to add support for HitFilm Pro.

    Have you got HitFilm Pro 2017 installed? If not, you can try to install the demo and try to install the Red Giant plugins again:

    Download Windows 64-bit installer »
    Download Mac 64-bit installer »

    The plugins won't load in the demo version but if you have the files on disk then HitFilm Pro might load the plugins.

  • edited December 7

    Thanks Cedric - I will contact Red Giant with the issue - I will reinstall HF 2017 and see if that works :)

  • Hi @all,

    i tried it with HitFilm Pro 3,4, Hitfilm Express 2017 and Pro 6. Nothing works. It looks like Universe 2.2 is the problem and there are no link where i can download the 2.0 or 2.1 version.  @saros - any news from Red Giant ?

     

    Cheers

  • @LordMcNau You should probably contact Red Giant as well since you are on a different OS. If anything, it'll let them know that people are trying to use Universe in HitFilm. If they know there is interest, they may add support sooner.

  • This is probably not much help but I had Universe 2.1 working just fine in Hitfilm.  I choose not to re-up my subscription and never bothered to update to 2.2. 

  • Universe 2.2/2.2.1 is working for me in HitFilm Pro on Windows 10

  • Does not help me on OSX ;) But i have contact the Red Giant support and still hoping for a solution...

  • @LordMcNau I know it doesn't help with macOS but @saros is running Windows and having problems ;)

  • Red Giant have so far ignored my support ticket - will update. I still have had no joy getting the plugins working with Hitfilm Pro - @Aladdin4d are your installations for both Hitfilm and Universe in the typical installation directories?

  • I just found that within the Red Giant Link Installer that the host apps listed are Adobe After Effects and Premiere - HitFilm not listed - I have sent a support ticket on this specifically just now - update if they respond ...  

  • edited December 14

    Ok I thought try something and installed DaVinci Resolve - then updated Universe Plugin - which installed OFX - voila they show up in Hitfilm - the problem seems to be the selective install from Red Giant not recognising Hitfilm as a host app.

  • edited December 14

    Since the path where HitFilm is installed changed in version 6, Red Giant may not have had time to update their installer to detect HitFilm Pro yet.

    Glad you got it working.

  • @saros I know it's too late since you have it working now but the answer ia yes, everything is installed in the default directories. I also already had Resolve installed before installing Universe so that is probably the difference. 

  • @saros Yeah... thx a lot man. This solution works for me.

    Cheers...

Sign in to comment