Results of "Cast Shadows" are Jagged and Blocky

I'm having a terrible time trying to get " cast shadows" working properly in a particular scene.  The scene is a city scape with modeled buildings and roads.  When I enable "cast shadows" on a directional light the created shadows look terrible!  Straight edges of 3d models create shadows that are jagged in places, blocky and low res in others.  I've increased the shadow map size to 4096, and I've tried moving the light closer and further away.  Even if it did work when closer to the objects that are set to cast shadows, that would not do any good as I need the light on the whole scene so it has to be a fair bit away.  Shadows seem slightly better when using a point light but the price of the additional processing overhead is not worth it because the result is still unacceptable.

I'm using Hitfilm pro 2017 but I've been demoing Hitfilm for 2018 and I'm having the same problem there.

Hopefully I'm doing something wrong and someone has a tip to get my shadows looking... well, like shadows.

 

 

 

 

Comments

  • I struggled, struggle with this all the time. Some of its model geometry. Light positioning is a trick to get those edges to go away...far away isn't so good, close is under lite. Trust me I feel your pain.

    I have used close medium power lights casting shadows and far away low power directionals lights w/o shadow casting to fill. Works good at times depending on the edge.

    The rest is usually setting which you seem to understand. Check this from a few months back...

    https://hitfilm.com/forum/discussion/comment/96134/#Comment_96134

    What building models are you using?

  • edited November 27

    @GrayMotion  Thanks for the reply.   I'll give your suggestions a shot.

    The models I'm using are the "K 14 Building Set"

    Free from here - https://www.turbosquid.com/3d-models/free-3ds-mode-building-ready-city/690329

    And the other model is "small shops"

    Also free,  found here - https://www.turbosquid.com/3d-models/free-small-shops-3d-model/243586

    Small Shops has been problematic from the get go.  Mostly with flipped normals.  I've spent a lot of time trying to fix it because the design of it is exactly what I need but this is not the first time it has caused issues. 

  • Hi @TTSProd,

    I just tried the first model from the K14 building set in hitfilm 2017 pro. It took a few attempts as the obj files wouldn't load and the materials in the 3ds files were a mess. The FBX file though seem to work fine. I added a spot and an directional light and both looked smooth and fine. 

    I think @GrayMotion is right it's something with the setup of your scene. I'm not savvy enough to know what though

     

  • Hi @DreamArchitect,

    Thanks for checking into it!  The K14 buildings work quite well for me too.  It's the darn small shops model where the shadows are terrible and I can't find another model that could take its place because its the only model that fits aesthetically and has an interior.

    I guess I will have to muck around in Maya and see if I can fix it.

  • Sorry I cant check the electrical shop model for you. Maya extensions (ma, mb) cant be imported into Hitfilm. Hope you get it fleshed out.

Sign in to comment

Leave a Comment