I don't know if i suck at research, or the file is bugging out.

edited November 21 in Express Support

I'm trying to record gameplay to edit in HitFilm Express 2017, with a capture card. I've converted the file multiple times (from the original .ts) to work with HitFilm, but it doesn't. Please help.

Comments

  • Triem23Triem23 Moderator

    What capture card are you using. 

    What software are you using to convert, and to what format?

    While we're at it, what are your computer specs? CPU, GPU, OS, RAM and storage? 

  • edited November 21

    1. AVerMedia LGP Lite

    2. Uh... i might be inefficient, but i just edit the extension. The video file still works the way it should.

    3. OS: Windows 10 Pro (1607), Processor/CPU: AMD A6-5400K, RAM: 4GB (3,47 (Or, 3.47)GB), Storage: 189GB Usable

  • @Zozimoto Can we get a MediaInfo report from an original capture?  Instructions for using MediaInfo are @ 19:33 in this excellent video.

    https://youtu.be/Yqhl0mRuTng

  •  

    Have fun.

  • @Zozimoto Thank you for the report, it has some important clues.

    The first thing to talk about is the file extension and the container being used. When it comes to video files, the extension indicates the container format being used to hold the video and audio streams. You can think of the container just like a multi-compartment storage box. Audio goes in this compartment, video in this one, subtitles over here etc etc.

    Your original recordings use the MPEG 2 Transport  Stream container format. (file extension ts = Transport Stream). This is a container format HitFilm supports, but HitFilm does not recognize the .ts file extension so it won't import the file. You can change the extension like you've already tried, but you have to change it to one that still matches the container format. If you like at the General section of your MediaInfo report the last entry is:

    FileExtension_Invalid : ts m2t m2s m4t m4s tmf ts tp trp ty

    It's saying that because you changed the extension to MOV, a completely different container format. Luckily, MediaInfo gives a list of extensions that do match the container format so you can choose one HitFilm also recognizes like .m2t. You were on a right track, but chose the wring extension to try. Change the extension to .m2t and HitFilm should import your recording.

    Having said that, the compression settings for your recording means it won't perform well in HitFilm so you probably want to go ahead and transcode to something that will. Using Handbrake to do that is covered in the video I posted earlier @ 23:43 and @NormanPCN gives more in depth details in his thread about it here:

    Transcoding to fast decode AVC for timeline edit performance

    I have no idea what options you can set for your capture settings but if you can set some advanced options you might want to do some research and see if you can set things up so you don't have to transcode.

  • Thank you @Aladdin4d for helping me, it now works.

Sign in to comment

Leave a Comment