Complete Amateur: Playback of 1080p mp4 file choppy but fine in Windows Media Player

Hi,

Literally just starting using Hitfilm Express. Have loaded in a 1080 mp4 film taken with my Windows Phone and when I play this file in Hitfilm the playback is choppy but when the file is played in windows media player, the playback is just fine.

I have made sure the project template matches the requirements of the file, which are:Width1920xHeight1080, Data Rate 16225kbps, Total bitrate 16416kbps, 30 frames a second.

I have only imported this file into hitfilm, no editing has taken place at all.

My PC spec:Ryzen 3 1300cpu, Nvidiai Geforce GT1030GPU, 8Gb RAM, Windows 10 Home 64Bit.

Am reading the manual as I type, btu thought I would post this question up here too. Any help would be great, thank you.

nictu.

Comments

  • Triem23Triem23 Moderator
    edited October 15

    Long story short, what Hitfilm has to do is a lot more complex than what Windows Media Player does. WMP just streams and tosses frames, Hitfilm has to hold segments for accuracy in editing. Being a phone video it's probably variable frame rate, so Hitfilm is doing extra work to conform as well.

    First 16 minutes of this video talk about how video decoding works. You could probably see performance benefits by transcoding video before import into Hitfilm. The rest of the video is about that.

    https://youtu.be/Yqhl0mRuTng

  • Hello,

    Thanks Triem, I thought this would be the case so thanks very much for verifying my thoughts.

    nictu.

Sign in to comment

Leave a Comment