Importing a composite shot to a new project

I've done a composite shot that I want to continue to use in each of my projects.  It's basically just a title intro that slides into the lower part of the screen to introduce someone.

When I open it to edit it, the background is transparent.

When I import it into a project and include it in my editor timeline, the background is black and it covers my original scene.

Is there something I'm missing when exporting or importing?

 

Comments

  • When you say import it into a project. What did you import? Did you save the composite shot to a Hitfilm composite shot file and import that or did you export (render) your composite shot and import that video file.

    Most exports will have a default black background in transparent areas because the video file does not support alpha information.

    By saving your composite to a separate composite shot file then when you import that, it is completely re-editable.

  • I made a separate composite shot project on it's own, exported that, and then just imported into the new video.

    Yeah, looks like pulling it in and then just using a Demult every time will be the way to go.

    Thanks!

  • @usmdesigner You can export to Cineform RGB with an alpha channel. On Mac Prores with alpha. Those formats will preserve your alpha. Demult works, but if anything in your comp has black (or close to it) then Demult will convert that to (some level of) transparent as well. A video file with alpha will always work regardless of what colors your comp has.

    Depending on what seems best for this circumstance, you might look into saving your composite as a Hitfilm composite shot. If it is a complex shot, aka slow to render, then a video file with alpha might be best.

  • edited October 11

    I'm trying to take a Composite Shot from one project into another and I can't figure out the steps. I managed to save the composite shot as an HFCS file but when I imported it into the MEDIA tab in my new project, I get (an exclamation point inside a triangle for my icon and) "File Not Supported" underneath the file name.

    Edit: okay, it has to be imported as a composite shot and not as media. I don't really see why the software doesn't just automatically identify and import it as a composite shot.

Sign in to comment

Leave a Comment