FPS issues?

My 25p video files are being shown in Hitfilm as being 24p?

When used in 25p project, the audio goes out of sync as for some reason it thinks it's 24p?

It is 100% 25p footage, shot on Canon C300 as is not variable frame rate?

If I enter the clips settings an manually change it to 25p, everything works fine!

Why is hitfilm thinking it is 24p when I import the media? Changing 78 clips manually tonight has bored me to tears!

Comments

  • Not sure why it thinks that, but I am pretty sure you can go to the Hitfilm settings and make the default frame rate set to whatever you need.

  • Triem23Triem23 Moderator

    That's strange. I don't have a c300, but the c300 uses the same MPEG-2 in MXF codec as my Canon XF 305, and I've not had footage coming in with an incorrect frame rate. Then again, I'm from the USA, so I'd be shooting 23.96 or 24 anyway. 

    Maybe you should contact support? Most Hitfilm users are bringing in Mp4 or h.264 in MOV format. Not as many in MXF. 

    In the meantime, I've not imported anything MXF for a few months. A recent update added native support for variable frame rate footage, but I've noticed a few glitches since then (phone footage, theoretically at 29.97 reading as 24 or 25... With MediaInfo reports on the footage showing the VFR dropping as low as 20.).

    There's reasons no other NLE supports VFR footage, and Hitfilm adding that feature might have created issues. 

    Anyways, support: https://hitfilm.com/questions/submit

Sign in to comment

Leave a Comment