Remove then re-add a logo

I'm looking to add an extra dancer to this video from Sia...https://www.youtube.com/watch?v=iujQgWDFZc4

At first glance it seemed easy until I realised the new dancer (green screen) had to be behind the #Idol Fox logo.

I tried to remove the logo using tracks and masks (OK) and then add it again but without success. If I mask the video *but* for that area then it overlays the added dancer.

Any suggestions?

 

 

Comments

  • Aladdin4dAladdin4d Moderator
    edited July 7

    I would try VirtualDub with the MSU Logo Remover plugin first. Here's a before and after frame.

    There are several logo removal plugins for Avisynth but that's much more involved to set up. 

  • @Aladdin4d what version did you use, as your second hyperlink is also to Virtualdub.org?  3.0b seems to be the latest, but any caveats?

  • That looks promising. 

    I guess I then save a frame of the original video, cutout the logo on a transparent background and then put it back into a composite shot as an image with opacity.

    Many thanks

  • Triem23Triem23 Moderator

    @tonyg this is the font FOX uses for the station logo

    http://www.myfonts.com/fonts/fontfont/good/ot-black/

    So, rather than cutting out the logo, I think you can just use this font, create white text and take opacity down to about 15-25%

  • But if he does that he'll get it looking correct over the extra dancer, but doubled up where the dancer didn't cover it. He'd have to rotoscope it to only be applied where the extra dancer has covered the original.

  • Triem23Triem23 Moderator

    @Palacono I should have specified I'm assuming tony will remove the original  logo with virtualdub first?

  • edited July 7

    VirtualDub 1.10.4 installed with MSU Logo Remover  3.0b

    File / Open Video File and select the mp4
    Video / Filters / Add and select MSU Logo Remover
    Detection (First Pass) with Logo Location as bottom right
    OK and OK
    File / Run Video Analysis pass... and wait
    (no logopack file is created)
    Video / Filters and select MSU Logo Remover|
    Removal (second pass)
    FILE / SAVE AVI

    ... ends up with a black video.

    @Aladdin4D (or anybody), what am I doing wrong and/or can you share how you did it?
    Also I can't find an option to export as mp4 (which isn't a great problem)

    Thanks

    <edit> Actually, might be getting somewhere now. Could still use some help though

     

    <edit2> Nope. It seems to detect the logo in the first pass but I still can't find the LOGOPACK file and when I run the remove portion the output video goes black

     

  • Aladdin4dAladdin4d Moderator

    @Palacono Link fixed. No Caveats and like Triem23 assumed, once the logo is removed, putting it back with the right font is the way to go.

    @tonyg Try it with the FFMpeg Input Plugin. VirtualDub and MP4 don't always get along and this will probably help on the decode side. Just drop it in the plugins folder like any other plugin and to use it, go to File-->Open video file and set the Files of type to FFMpeg Supported Files.

    VirtualDub won't directly export MP4, it's really designed for AVI export only. If you have GoPro Studio/Quik Desktop installed (free) you can export to Cineform which is a great choice for Pro/Express 2017. Much more detailed instructions on using VirtualDub to transcode to Cineform are here:

    How to Use VirtualDub FilterMod to fix VFR issues and convert to Cineform

    I just did the same steps you did and yeah, the first analysis pass can take a while. I should have mentioned that, sorry. Once the analysis pass is done you should be able to go straight to removal without having to hunt down the logopack file. Just leave that at the default. I  suspect the black screen has to do with what the export settings are. Do you remember what you used?

  • edited July 7

     @Aladdin4d link still as before and forum isn't showing you've edited your post. Refreshed page a few times: no change. Maybe it'll catch up.

    As OP has plugin, only of interest to other readers though. :)

  • I got the FFMpeg Input Plugin so can load the mp4 ok.

    Not sure about  export settings where would I find them?
    Anyway I have now used logoaway plugin (which actually heavily blurs the logo). When adding the logo back in the same place it all looks OK especially as we're concentrating on the silhouettes at the beginning.
    So I now have 

    - Logo text layer
    - Green screen dancer
    - Original video with logo blurred out.

    Thanks for all the help

Sign in to comment