Problem with Mocha after HitFilm Pro 2017 Update #4 (Resolved)

edited May 30 in Pro Support

Just installed update #4 on a machine also running Vegas Pro 14 Suite. This leads to multiple error windows "BCC Error: Could not load library ..." in HitFilm (BCC plugin are not working in HitFilm anyway because the license restricts the use to Vegas). This already happend with the original install and can be fixed by uninstalling BCC, deleting several folders and reinstalling BCC (Google found that for me).

But there is another issue: When loading a project with masks tracked by Mocha I get the message "This project file uses a plugin that cannot be found...". The Mocha effect (and all the work I put into the tracking and the masks) is gone in the project. A project created from scratch with Mocha loads without problems.

Any help is appreciated. Now I'll try to go back to the previous version...

Update: Downgraded to Update #3 and the projects work correctly. So there must a difference between the two versions.

Comments

  • AdyAdy Staff

    Hi @FrancisFord,

    Thanks for raising this, sadly yes it does look like there is a problem here. I have raised this as a high priority to be fixed & we are investigating right now.

    We have a good relationship with Imagineer & I'm hoping we can get this resolved ASAP. 

    Please accept my apologies for the inconvenience, it's extremely disappointing that we didn't catch this error ourselves.

    Ady

  • @Ady, Thank you for the reply. While it doesn't make me happy I understand that these things happen. I am in the software industry for almost 30 years now...

  • Is there any timeline for when we can expect a fix for the Mocha issue introduced in update #4?  I would love to take advantage of the new features and fixes in update #4, but the Mocha issue has me stuck at update #3.

  • AdyAdy Staff
    edited May 19

    @FrancisFord & @TTSProd - An update (5) for HitFilm Pro 2017 should have went out yesterday. This contains a fix for the mocha issue.

    Please accept my apologies for the inconvenience caused.

  • Just to confirm: The fix is working...

  • AdyAdy Staff

    @FrancisFord - Thank you for confirming the fix, I'll close this thread as your issue has been resolved.

This discussion has been closed.