Performance issues, playback in viewer stutters

Hey guys, I've already gone through a bunch of threads but none could really help me.

My Specs:

i5 3570K @ 3.4

16GB RAM

GTX 1060 6MB

I pull a clip into the timeline and it plays Ok. As a test a added Auto Color Correct and with the effect applied it stutters in every setting but Quarter. Making editing impossible. I could not find the "Preview render", or "RAM preview" buttons mentioned in the manual.

It happens with my GoPro 4k footage but also with my DSLR 1080p footage.

 

I am used to Adobe programs and there I would just hit the Render button and after that it would play smooth.

I tried to recode my media with VirtualDub, following this post.

http://hitfilm.com/forum/discussion/42015/how-to-use-virtualdub-filtermod-to-fix-vfr-issues-and-convert-to-cineform/p1

I followed all the steps but couldn't import the media after conversion.

I really would like to solve this issue as I am in the progress of finding the right editing suite for me. Hitfilm Pro looks like a great alternative to Adobe, but if it performs like Express just doesn't work for me right now.

 

Comments

  • In Hitfilm 4 Express, Cineform in AVI (Video for Windows) probably will not perform as well as DNxHD or maybe even Cineform in Quicktime MOV files. Another good option is fast decode AVC in MP4 (Norman AVC).

    Cineform AVI in Hitfilm Pro 2017 on Windows is the best performing media format in Hitfilm Pro 2017.

    Have a look at this thread.

    https://hitfilm.com/forum/discussion/42349/transcoding-for-better-performance-and-easier-editing

  • Thanks for your reply Norman!

    I tried it out and the 1080p footage plays now smooth with Auto Color Correction applied.

    The 4k GoPro footage still stutters after the color correction. I made it proxy but that didn't help either.

  • 4k work requires a powerful PC. Your i5 at 3.4Ghz probably falls short. See this thread about 4k work. Unfortunately it is mostly about Hitfilm Pro 2017. 2017 does perform a bit better than version 4, which wis where Express is right now.

    You might try creating a custom profile in the Nvidia control panel for Hitfilm and set the power options from default to prefer max performance. I don't have high hopes for this but it is easy to do and worth a try.

    https://hitfilm.com/forum/discussion/42285/hitfilm-timeline-4k-performance-demo-video

  • I tried the power option but it really didn't do much, if anything at all. I tried some compositing and using 1080p everything is smooth so far. As I usually don't use 4k anyway I can live with that. Thanks for your advice Norman. Really nice and helpful community here!

  • edited October 19

    After reading lots about this problem, here the solution for Hitfilm PRO 2017
    source try to use Handbrake to get an mp4 with anamorphic auto, modulus 2, codec h.264 (x264) constant frame rate, encoder preset in slower and constant quality between 20 and 22, convert

    Once you have your mp4 this way, convert to GoPro Cineform using Hitfilm, Quality Medium.
    A 1 Gb mp4 will now be an 18 Gb avi aprox (1 hour to convert)

    Load your Cineform avi into Hitfilm, almost zero lag fwd and rev, no need for proxy or cached ram. (well, depends on your video size, 720, 1080, 4K) the difference in response is huge using Cineform.

    Why? Hitfilm PRO 2017 now has native encoder/decoder for GoPro Cineform.
    VLC player requires a plugin for Cineform codec. (Not needed at all since the idea is not to reproduce it, just edit it in Hitfilm)

     

     

  • Aladdin4dAladdin4d Moderator
    edited October 20

    @OscarUnique You don't have to transcode twice. If you go the Handbrake/NormanAVC route you end up with files that are good for editing in HitFilm with performance that's much better than what you get with a file straight from the camera.

    Cineform does give you the best performance but you end up with much larger files. There's no need to go through Handbrake first you can go direct to Cineform using GoPro Studio, Virtualdub, or HitFilm itself. HitFilm will be the slowest to transcode so you're probably better off using one of the other two.

     

     

  • Performance Issues HitFilm PRO 2017. This comment is for those not pro at video editing. I did read lots of pages about the problem like you, so you may know how complex it is, so based on my investigation results, here my experience. This was originally an MKV video first converted to MP4, so if you already have an MP4 go to the MP4 section.

    Original Video 1.09 Gb 800 x 600 / 30 MKV (Not accepted by Hitfilm the mkv)
    Step one: Convert to mp4 with Handbrake according to investigation best option
    Settings: Anamorphic automatic
                        Modulus 2
                       Frame rate 30 (constant: very important, constant
                       Encoder preset: Slower (Balance size vs quality, good option)
                       Constant quality: 22 RF (no less than 20)
    Result: (about an hour) 791 Mb mp4 video (not bad even when the idea was not to compress)

    MP4 Section

    Step two: Open in Hitfilm PRO 2017
    Result: Terribly laggy

    So, Follow recommendations, the very best option for Hitfilm PRO 2017 is CineForm, so convert mp4 to cineform using Hitfilm itself

    Step three: Two convertions made, mode GoPro Cineform :
    One: Film Scan 1, Result: 28.1 Gb (an hour or so to render)
    Two: Medium (recommended if not pro work needed), Result: 18.1 Gb

    Step four: Open CineForm Medium Quality in Hitfilm PRO 2017
    Result: (took some time to load the 18.1 Gb video) and WOW, zero lag
    Test with Film Scan 1 video not done, no need by now.
    Note: if you use VLC player, you will need a cineform-vlc-plugin

     

  • I will second the notion that a double transcode should not be necessary. Don't generate an MKV from whatever source is creating the original file. Then transcoding to Cineform is much simpler. Otherwise just remux the MKV to save time. The Handbrake settings suggested are not so good. Of course it will not edit well. Why use Slower when it is just an intermediate file. The slower encoding presets are all about making a file smaller. They take a lot longer to encode. File size is something we do not care about with an intermediate file that will be again transcoded. Also often one can get by with a single transcode in Handbrake with fast decode AVC settings. Worth a try.

    The transcode thread listed above is a good source for all things transcoding.

  • Aladdin4dAladdin4d Moderator

    @OscarUnique

    "Settings: Anamorphic automatic
                        Modulus 2
                       Frame rate 30 (constant: very important, constant)  
                       Encoder preset: Slower (Balance size vs quality, good option)
                       Constant quality: 22 RF (no less than 20)"

    Change Encoder preset to Medium. In the same section select Fast Decode next to Encoder Tune.

    Encoder Profile: High

    Encoder Level: Auto

    In the Extra Options box enter the following: "keyint=8:bframes=0"

    Now when you transcode you are probably done. These settings are known to give good timeline performance.

    If you would still prefer to use Cineform then there's no need to use Handbrake at all. Virtualdub Filtermod can take you straight from your mkv to Cineform with a constant frame rate. Step by step instructions are in this thread.

    https://hitfilm.com/forum/discussion/42015/how-to-use-virtualdub-filtermod-to-fix-vfr-issues-and-convert-to-cineform

Sign in to comment

Leave a Comment