Particle Simulator Layer Choice Not Displaying

edited January 11 in Pro Support

Okay. I've gone through this video frame by frame, and I cannot figure out what I'm failing at in HFP2017.  https://www.youtube.com/watch?v=KKWk0cR9RHE&index=20&list=PL8JZuYgUW4jIGZPZAPgiaYsIzTPfjWml1&t=227s

It says "in the particle systems appearance properties, set it to use the 3D model layer."  When I select Layer (not None and not Built-in), no additional dialogue box appears to allow me to select the model layer.

What am I missing?

Thanks ahead of time.

(Meanwhile, I'm going to manually create 74 more models and set them by hand. It's too obvious to me that I'm really not up to doing this sort of work.)

Comments

  • Triem23Triem23 Moderator

    Out on my phone now. When I get home, I'll upload the screenshot, if needed. Once you select "Layer," a triangle icon for a dropdown should appear. Twirl that open for the layer selection dialog. 

    Watch this. Old HF2U tutorial on particle textures. Only difference for a model is selecting a model layer instead of an image. 

    https://youtu.be/5e69TDpvxko

  • edited January 11

    At 1:27 on the above video tutorial, that secondary selection area he's selecting a layer from that appears underneath once he sets the appearance properties selection to Layer, instead of None or Built-in, is what's not appearing for me. I must be missing some switch. Gawd, I feel so stooooopid.

  • Triem23Triem23 Moderator

    You're going to facepalm in a moment....

    So, in your own screenshot and project, see where you've selected "Layer" as the particle texture source?

    Ok, skip that dropdown  right below it that says "Frame." That's where to set start frame and frames used for animated or video textures.

    So the next line down that says "Source Layer...." That's where you select the model layer or media layer you want as the texture.

    If it was a snake, it would have bitten you.

    In your defense, the control was moved in Hitfilm 2017. In Hitfilm 4 pro, the Source Layer  dropdown is right underneath the Texture Source dropdown. In HFP 2017 the frame selection controls for a media source layer got moved above the Source Layer menu from right below it.

  • edited January 11

    Oooo-kaaa-aaaaaaaaay!  Sigh.  Told you so.  Dumb, dumber, dumbest. And I'm not even blonde.  Thanks, @Triem23 .  Gawd!  ...Oh, and, yes, I already built and set 74 other fleet ships.  I'll strip them out and try the particle simulator, again.

  • And no dice for me.  I must have set something above wrong, because:

    Under General >Appearance, when Texture Source is selected to Layer and Frame appears, regardless of whether I set Frame to Single, Random, or Animated and no matter what settings I use for Seed, the Source Layer beneath Frame only has None as an option...and, yes, I have two model layers in the comp along with Particle Simulator, a camera and lights.  There must be a switch higher up I'm missing, so, for right now, I'm hanging this up until I can hit the reset button on my brain. I hate doing blonde.

  • Triem23Triem23 Moderator

    Are you clicking on the downward pointing arrowhead to the right of the field which says "None?" It's a drop-down field and should show you all the valid layers in the Composite Shot. 

    Hmmm. Still a Hitfilm Pro 3 tutorial, but maybe Inscape's tutorial on this will be better for you than Simon's. 

    https://youtu.be/sOrOWMSHC-k

  • Yep. I am. A nice bright blue window appears and, in it, it says "None".  I need to start fresh when my brain clears out.  I'll work on it.  I saw that video, too. I'm about ready to bring up Hitfilm 4 Pro which I still have on drive and do it there to see if it works.  But not right now. I'll revisit this in a less brain-slawed condition.

  • Triem23Triem23 Moderator

    I don't get it! Ok, well, I'll share this before it's official launch. 

    At about 6:40 I set up a custom layer particle texture in HFP 2017. I'm doing it to the Appearance setting of a mobile emitter, but it's exactly the same as doing it to a particle appearance. In this case it's setting up an animation texture, but the procedure is the same with a model layer. I actually did one with a model layer last night just to double check myself before typing "you're about to facepalm..." 

    Oh well. 

    https://youtu.be/ZPpbA6AoQFk

  • edited January 11

    @Triem23: Absolutely clear, concise, well-demonstrated, and supremely helpful. You did a top-end job on that tutorial. Impressive tutorial, impressive results.

    Side note. I pulled up HFP4 and everything works there just fine. Was able to create a mock fleet using the particle simulator. Just can't replicate it in HFP2017...yet.

  • Triem23Triem23 Moderator

    Thank you. I think I did three recordings on that to be happy with it. Lesson learned--don't speak 100% off the cuff... Outline first.

    I'm wondering if you are having a weird bug in 2017 I'm not having. It shouldn't be fighting you! Of course a HF4P fleet can move into HFP 2017. 

Sign in to comment

Leave a Comment