[Bug?] When Rotating a 3D Plane using the Atomic Particle Effect...

Here's what happened:

  • I created a 2D plane
  • I applied a 4-Point Color-Gradient
  • Added the Atomic Particle effect
  • Adjusted the number of particles to 800 and size to 7
  • Imported my audio file
  • Added it to audio interaction
  • Adjusted the Fractal and Disperse options
  • Converted the 2D plane into 3D
  • Rotated the plane on the x-axis by 90° (to make it flat)
  • Hitfilm turns unresponsive and my entire PC is lagging like hell and almost unresponsive as well
  • After it finally loads, the plane is there, but when clicking into Hitfilm, it lags out my PC again and I have to force-close it
  • I checked the performance of my PC; everything normal, no significant increases in RAM or CPU usage
  • Hitfilm 4 Pro is up-to-date and all my drivers are updated as well
  • System can easily handle the program; haven't had such issues since
  • This crash could be recreated every time for the last few times I tried to do the same thing

Any advice?

Thanks :)

Comments

  • Triem23Triem23 Moderator
    edited December 2016

    First, you don't need to turn the plane 3D. Create a 3D point, and set the "Transform From" control to the 3D point. Rotate the point. 

    Bear in mind you've possibly found an actual bug, but set up the point and that should solve the problem. 

    Or, if you want the look of the 3D plane, make the Atomic layer 2D,right-click the Atomic Layer and select "Make Composite Shot." Move over effects. Back in the main comp, turn the embedded Atomic Comp back to 3D and try rotating. 

  • >>Create a 3D point, and set the "Transform From" control to the 3D point. Rotate the point.<<

    Good point. I just looked up the video again and yes, I remembered it wrong. He actually uses a point. So I will try that instead, thanks :)

  • Yw. Although rotating the point will preserve the psuedo 3D structure of the particles. Rotating a 3D plane will flatten Z-positioning. They're different looks. Anyways, I'm still thinking Hitfilm shouldn't crash from making an Atomic layer into a 3D plane. You still may have found a bug. 

  • @Triem23 I noticed a strange thing but I quickly figured out what it is.

    You see, I'm using LAV Filter (downloaded this long ago so I could play my movies). I noticed that, when recreating the steps above, Hitfilm or w/e is opening tons of LAV instances. I have 19 songs in that project and each of them has its own LAV instance. And they get suddenly multiplied by x amount when I do these steps. Closing Hitfilm and restarting the same project deactivates all those instances, but the same 19 LAV are up when I open the project (each its own). Pretty sure there is some really strange behavior with this.

    Any known issues with this? Because I'm not sure how to turn it off, either. Was so long ago.

  • Triem23Triem23 Moderator
    edited December 2016

    I'm not familiar with LAV. @Aladdin4d @Stargazer54 or @NormanPCN might have community insights--all three are more technically knowledgeable than I.

    Otherwise,  maybe a dev will have an idea when staff get back in the office on Monday. @Emma I never tag you. Today, you get the staff love.

    I can speculate that there's some funky interaction between Hitfilm and a third-party demuxer that's hijacking system calls. 

    How long ago did you install LAV? The latest release was last week. If you're using a years-old version, just glancing at the 2016 changelogs show me that it might be worth downloading the newest release. It might solve your problem.

    https://github.com/Nevcairiel/LAVFilters/releases

     

    If that doesn't work, you can try uninstalling LAV, although a quick Google search is telling me LAV doesn't uninstall cleanly. 

  • @CaptainWARLORD Yes filter packs like LAV and the defunct FFDShow tryouts can cause problems and usually codec packs like K-lite and CCCP are even worse. Luckily you should be able to turn off LAV for the formats HitFilm natively supports.

    Under All Programs you should have LAV Video Configuration, LAV Audio Configuration and LAV Splitter Configutation. Each one has a Formats tab where you can uncheck what formats trigger using LAV filters. 

     

  • >>turn off LAV for the formats HitFilm natively supports<<

    @Aladdin4d And those are?

  • Aladdin4dAladdin4d Moderator
    edited December 2016

    https://hitfilm.com/express/specs

    • Video: Quicktime, AVI, MOV, MP4 (AVC/H264 & AAC), MPEG-1 (TS, PS, MPE, MPG, MPEG, M2V), MXF (DVCPro HD), DV, HDV, WMV
    • Audio: AAC, MP3, M4A, MPA, WAV, WMA

     

     

Sign in to comment

Leave a Comment