My Very First Animation.

Well, I feel a bit stupid posting this because it's so very basic and raw, but it's my very first animation, and I used HitFilm Pro 2017 for it. I've had an aversion to video and animation for decades. My husband and his music has pushed the need to learn it, though, and I am SO happy to have discovered HitFilm, so, here, with all its amateurishness and all its warts, is my first attempt to animate our zentao / zentao.com logo and trademark:
https://www.zentao.com/zentaoLogoTM_Ani12_12-6-2016.mp4

 

«1

Comments

  • i see a lot of artefact in your video.

    the logo and animation is nice

  • I know, @ chriguf. I can't figure that out, since I used 1200dpi images saved at 4x the size of the 1920x1080px of the video. It makes no sense to me. I'm still learning, though. It might be I used too high a dpi and image size for import. I don't know. I can't find a whole lot, so far, on the problem in the user guide.

  • Why do the reflections only appear after everything stops moving?

  • @Palacono : Because I haven't figured out a way to do it otherwise.

  • It's a good start, as logo go's it is showing it's age a bit (80's) but otherwise a nice execution.

  • The artifacts on the edges of your spheres... Am I correct in thinking this is a duplicated 2D element that was originally on a white background? It looks like you're picking up spill of the original background. 

    Try using "Matte Cleaner," "Remove Color Matting" or "Spill Removal." One of those should be the right tool to clean up the edges.

    Reflections... Boy, that's a toughie... If these are all 2D sprites then there's no real way to do the Reflections besides hand animation. The problem is they call attention to themselves by "popping" in. Better to leave them out entirely for now. No one will really miss them if they aren't there, but they WILL notice the "pop."

    Drop the reflections, try those three filters mentioned above to clean up the edges of the spheres and you'll have a solid logo animation that's ready to go. 

    (and you can always work on reflections for a second version later.)

    Only other critique I have is try a render with motion blur turned on for all the sphere layers?

    Otherwise it's a good design, well animated (seriously, having all those objects fly in, accelerate then smoothly stop was a pretty advanced move!) with good colors. Nice work! Be proud of yourself for this project--you came out of the gate on your first try with a rather complex project! 

  • edited December 2016

    @Andy001z : Thanks, and, well, the logo and trademark is what it is. We are, after all, Gap Gen, not Millennials. :D

    @Triem23 : Ooo-kaaay.  I'm finding those referenced in the user guide.  And they _became_ 2D sprites because my attempt to import the logo and its elements as both 3D rendered models and even just as meshes went totally 'no go'.  The program simply resisted recognizing them, regardless of what file format I tried to use.  I'll drop the reflections, then. I tried having the reflections rotate around in sync with the balls, but that got the composite...and/or me so confused that it just hung. I think it was a case of "too much information" because I'm not familiar enough with the how-to.

    ADD/EDIT: And, thanks so much, for the kind words and encouragement.

  • Aladdin4dAladdin4d Moderator
    edited December 2016

    @DLKeur Kudos to you for even considering this one!:

    "It might be I used too high a dpi"

    That shouldn't make a difference in this day and age but I have seen that cause problems before and the vast majority of people would never even consider it as a possibility. Compared to print, video DPI is very very low. For some reference points Win 7 and up use a range of 96 to 144 for the display DPI and you hit "Retina" quality at around 240 DPI with anything over that being pretty much superfluous. Really large format displays (think big trade shows) can actually look better going with a lower DPI like 72-75. Anyway I'm getting a little off base here just to say as a general rule 300 DPI should be a good max limit and realistically 150 is probably just fine.

    Having said all that I'm with @Triem23 on the cause of the artifacts and don't think the high DPI was a major contributor. He already hit the HitFilm tools that should clean things up. If we're right about the white background what's causing the artifacts is the anti-aliasing applied when the original bitmap was created. Assuming you have Photoshop and I'm remembering the name of the tool correctly, Defringe should be an option to clean up the edges before you even get to HitFilm too.

    Reflections - I'd say get rid of them for now but my first thought on putting them back in would be make sprites of just reflections, rig and animate the same way you did the spheres and keyframe the opacity so by the time they spheres stop moving you're at 100%. With the motion blur Triem23 mentioned it might work out.

     

     

  • @Aladdin4d : The BG on the image was light. I am running Photoshop local on my machines, and, yes, anti-aliasing and defringe was employed.  It's like all my care went south once the rasters were imported and manipulated down to size.

    I'm usually running 2400ppi on my graphic files for glossy printing, so the megapixels are in the multiple hundreds for large format books and traditional magazines.  I'll try lowering the dpi and calculate the largest size I need for the video.  I'll mask off the background and render again 3D with the mask on and see if that allows me a cleaner shot once they are reduced to .png flat images.

    I did try using transparented .png sprites of the reflections, but the number of layers in the composite was way more than I was able to keep track of.   I kept getting lost, even when I switched to my wall screen.  The calculations were amazing as were manipulating the beziers. 

    I'm going to rebuild from scratch and see if I can do better. I do have the logo and its elements rendered 3D without reflections, and that was my first version.  But, of course, my husband immediately wanted to know where the reflections on the logo were. :D

  • @DLKeur Remember you  can always render out two versions - one with and one without reflections.  (i.e. two separate composite shots or even out to separate files.)   Then bring those into the Editor and do a dissolve between them to minimize the "pop on" of the reflections.

    You could further cover the issue by rendering the first part in one color or surface and fading to the reflection version in another color/surface.  Then the dissolve idea would make more visual sense.  

  • @Stargazer54 : OMG!!!!!  You're right!  Wow.  THANK YOU!!!!!!!

  • Okay. Question concerning image quality: I just was going through double-checking my images, comparing them to the rendering done in HFP2017 viewer and in the exported Video, too (H.264, 30fps, 1920x1080) I see a noticeable difference in quality between the original .png and the video result. What am I doing wrong that is degrading the images? 

    Okay. For some reason, the image won't show, and it's only 85kb. Anyway, here's the link: https://www.dropbox.com/s/a20vj8y82z7seux/ComparisonInBandingOrigVsVid.png?dl=0

    Comparison

  • And the same problem is occurring with all of the files. I realize that monochromatic images tend to band, but I've reduced banding in these to almost nothing in their original sizes. saved as .bmps, tifs,, .eps, and .pngs.  I took in the master high-end raw files, resized to the largest and smallest they appear in the video, saved as uncompressed .pngs, then imported them, BUT, once exported, they come out extremely banded.  Again, what am I doing wrong?

  • Well, I've found the issue. Video, I guess, only renders at 8bit rather than 16bit or higher, so all the tricks we normally use to get rid of banding in monochromatic and gradient images (noise, spread, four-color overlays, etc.) don't matter once video compression engages during export. I have two choices, it seems: huge files and some banding or more manageable files and lots of banding. Bummer.

  • Triem23Triem23 Moderator
    edited December 2016

    Another thing to check includes project color depth settings--while video output to mp4 is 8-bit, working in a 16 or 32 bit color space project can minimize banding. 

    If you export OpenEXR image sequences you would have 16-bit output at larger file sizes. 

    Where is your final output ending up? If YouTube, Vimeo, DVD or Blu-Ray your final product is going to be 8-bit 4:2:0 anyway, so an OpenEXR is only giving you a higher quality master file.

    PNG sequences give the highest quality 8-bit output, again at higher file sizes. 

    As you've noticed, video files are a tradeoff between quality and file sizes. If you are outputting Variable bit rate, maximum should be 150% of target (i.e. 20 target, 30 max). For reference, for 1080p output most DSLRs capture at 35mbps. Most Camcorders capture between 28 and 50mbps. Higher end camcorders might go as high as 100mbps. A Blu-Ray would be 20mbps (max), and a Netflix, Hulu or YouTube stream is about 12mbps. In Hitfilm's Export settinga change "Profile" to "High" and "Level" to anything higher than "4.2." this will let you export at higher bit rates than default settings. 

    For your logo--a stock element you'll reuse--I would go for variable bit rate at 50 (target)/75 (max) mbps. For performance videos I wouldn't go any higher than maybe 25% of whatever the camera captured at (so if my camera footage was at 35mbps, maybe I would output at 45?). Outputting higher bitrate than the source won't magically create details, but will minimize additional artifacts from recompressing a compressed source. 

    Incidentally grab some DVDs or Blu-Rays or look critically at a Netflix or Hulu stream. You'll notice a fair amount of banding and compression artifacts. It's one of those things we tend to not notice as much in commercial releases, but instantly spot in our own projects. 

  • Thanks, @Triem23 .  Everything is slated for web presentation, so, ultimately, everything will be reduced to 8bit, I guess.  I'm just going to have to do my best, no worry the file size and bandwidth, and put up with some banding. 

  • No problem. Reread my above post. I was updating it when you responded to me, and there's additional information on output settings now.

  • Solid gold information, @Triem23 .  THANK YOU.  I haven't found that information in my Google searches.  You're pure diamond.  I've been working at 32bit and 48bit in my graphics for so long, I think I'm spoiled. It took me a LOT of work to create the original of this logo back in the 90s. I had a top-of-the-line, gold-to-gold contacts computer at that time running Win95 stripped down.  To do what I wanted at the capabilities at the time, I had to render huge, then do a lot of pixel-by-pixel work, without the benefit of a Wacom and stylus...which hadn't been invented, yet.  I got excellent results, but it took a solid six months of experimenting to do it.  Now, I guess I'm totally spoiled with the capabilities I'm used to, but it always galls me when I load a gorgeous image to the Net and then see it come out "less-than."  I guess this 8bit Net delivery limit is why the big companies are all going to clear, bright colors, while I prefer monochromatic and muted, muddy colors and the values.  Thanks for all your help and for your patience with this bass-akwards newb.

  • @DLKeur ; You're not a newb.  You are an artist learning a new tool.

  • Aw, you're welcome. This is a very helpful forum. 

    Next time I am on my computer (not phone) I'll link you my generic sphere model that loads up in Hitfilm. It defaults to a boring white, but you can have a play with the material settings, and try setting up some lights and planes with some gradients. Parent the spheres to your existing sprites, and maybe you can get a 3D version of the logo set up reasonably quickly. :-) 

  • Thanks, @Stargazer54 . But it sure does feel like it.  It's a whole 'nother world, and I knew that going in.  And there's no faking your way through this. It's one step at a time, read like crazy, watch some videos, try stuff, try some more stuff, DELETE, then start again. :D

  • @DLKeur I'm guessing you have much better displays than the average person and better displays make things like banding more noticeable.

  • @Triem23 : THANK YOU!  I'll try it.  I'm wondering if part of my problem might be that my meshes and my rendered models aren't using default specs, which is why HitFilm doesn't like them. I may try to re-render the models and export the meshes using program defaults.  I think maybe, like the images, I might be overdoing things maybe. That's a next week thing, though. Right now, I'm neck deep in re-inventing the math on a new interface for a new logo ani attempt.  The darn Pooki cat went and paper shredded my numbers.  BTW, I love the fact that I can scale the keyframes using select 3+, hold alt.  Makes life so much easier, that.  Ratios are easier in these calcs than are hard numbers, especially when having to add a second to the video length to slow the delivery down.  (My first and second versions sped by so fast, my husband told me the logo was out of breath. :D

    Oh, after one of your tutorials, I did a flaky fun thing with one of your preset sparkles and had it bouncing around like a rabbit, then gave it the illusion of disappearing down a black hole.  All illusion, of course, but there is such a huge amount of control with HitFilm and it's so much easier than other programs I tried before somebody on YouTube mentioned HitFilm as their preferred choice.  I'm over the top with how dumb-brunette-friendly this program is.  Really!

  • @Aladdin4d : I run calibrated screens, yes. I also run six relatively small screens from hot to cool so I can tell what things will look like on uncalibrated screens.  The wall screen is LED, but I hate it because I'm so 'down here' and it's so 'up there'. It is useful for when I need lots of working room, though...which seems to be the case with video.  The performance video snip I posted yesterday for a couple of hours so far has thirty layers in the Edit screen, and we're only a third of the way done with the video.  The composite on the logo is likewise tediously deep when messing with the keyframes of the animation, opacity, position, and size. I found that even my biggest screen just didn't give me enough elbow room, and I like seeing everything...which is part of the problem.  I want to know where number seven's correlate position s when working on number one satellite.  I don't know how you guys and gals do it.  Really. I've got notes scribbled over notes to try to keep track of it all.  I'm sure it will get better and easier and less complicated as I get a handle on 'how-to'...if I don't drive everyone to drink before then. :D  Thanks for all your help and patience. <--and that's to EVERYONE.

  • Which tutorial? 

    To clarify a minor point, we Moderators aren't FxHome Staff (staff have staff badges), just users who have been given some forum editing access. It was a morning early in August when Aladdin, Stargazer and I logged in and discovered to our mutual surprise we had badges. To be super-pedantic I think my moderator status predated Aladdin and Stargazer by a day.

    Anyways, we're just three of the many helpful users here. You've already "met" a few of the others in this very thread. 

  • I'm not sure which tutorial, now, @Triem23 : It was on YouTube and offered itself after another one finished, auto-starting.  But it made me brave enough listening and watching to try playing a bit with some of the effects that have little cubes by them that can become independent layers themselves.  Playing like that gave me a glimpse of what might be possible in the 3D environs using keyframing and the bezier controls.  It opens up a whole realm of possibilities that allows for taking things beyond 4D into more mathematically complicated environs, yet still projects them onto 2D simulation, which is like super-charged brain-candy for me as a concept.

  • Ok, this is a link to the plain sphere model I mentioned a few posts ago. I've just loaded this into HFP 2017 Update #1 and it's correctly importing and working for me. Which makes me happy. Cuz I built it. ;-) Well, ok, it's a sphere, so I clicked a create sphere button, applied a basic spherical UV mapping type and exported it.

    It's a plain white sphere and it's what I bring in for all my basic sphere needs. Again, it's UV mapped if you wanted to wrap a texture on it or build your own bump maps.

    Download Plain Sphere 3DS

  • @Triem23 : Got it.  Thanks.  I'll go try to open it.

  • @Triem23 : Okay. It opened and imported just fine.  So why won't my .3ds files?  Sigh. 

  • @DLKeur it's not being 8 bit that causes the banding, it's (possibly) exporting in MP4 format. See my thread here: Palacono-moaning-again

    Scroll down to #34

    Exporting as just about anything else either removes or reduces the banding. I've not installed HFP2017, but that has Compressed AVI Export which might be closer to the AVI quality that I found looks the best in HF4.

Sign in to comment