Particle Simulator inside 3d model is not seen through window from outside

I have made a smoke filled room with a particle simulator inside a 3d model that has windows.  From the outside the particles can't be seen through the windows which are set to 50 % opacity in the materials setup of the 3d model.  I can see all the other 3d models in the room through the windows so I don't understand why I would not be able to see the particle simulator.  All 3d models and and the particle simulator are set to 3d unrolled.  Anyone have any insight on to how I might make this work?

Thanks,

Ken

Comments

  • Which version of HitFilm are you using? Are there any 2D layers on the timeline?

  • I'm using Hitfilm 4 pro.  There is one 2d layer, an image for the projector effect, visibility is turned off and it is below all the 3d layers.

  • AxelWilkinson

    I'm still having this issue of the particle simulator effect not being visible through the windows of my 3d model but as I have continued to work on the scene it has changed slightly.  I've brought in a composite shot that has some chroma keyed characters in it.  This is set far back in Z space so they appear at the back of the room.  Now I CAN see some of the particle simulation effect through the windows but it cuts off right at the point in Z space where my chroma keyed characters are placed.  Its like there is an invisible wall at that position and I can only see particles behind that wall through the windows from outside the model, but as soon as I open the door of the model I can see the particles filling the room as they are supposed to.  If I move the composite of the characters forward in Z space the "invisible wall" that the particles are stuck behind moves forward with it.  I've run out of ideas on what to try to change to fix this.  I've changed where the composite layer is placed so it would be above or below the particle simulator and 3d model of the house in the final composite.  I've tried different settings for the composite layer, 3d plane and 3d unrolled behavior is the same and 2d is useless to me because I need to place the layer in Z space so the characters appear behind a 3d object in the house (a table).  I've tried to move the particle simulator effect to it's own composite shot and bring that back into the final composite. I even set the opacity of the windows in the 3d model to 0% to see if it would change the way the particles appear.  Nothing I have tried changes anything. If I turn off the visibility of the house model, the particle simulator affect appears exactly as it should.

  • edited August 2016

    Here is a picture to demonstrate my problem.  If you look through the side windows beside the open door you can see the defined line where the particle simulator effect cuts off but through the open door the effect appears as it should.

    https://drive.google.com/file/d/0B3WrqYNz894HdWxUOEFGN2N3U0E/view?usp=sharing

    Sorry I  can only provide a link to the picture because I can't figure out how to post the picture directly into the forum.

  • edited August 2016

    @TTSProd - Pics can't be uploaded directly- what you did is fine ( you can use other picture hosting sites too such as flickr.com) but I'm on a work computer that restricts drive.google.com and all file sharing websites. I'll have to look at your pic when I get home tonight after work. But I'm sure someone can get you on your way.

    I did a quick test with a 3D model house, placed a particle sim inside and masked the windows - the first mask being set to add and the subsequent ones set to subtract. I can see the particles inside the house through the windows. I have the house and the particle sim both set to 3D plane with the house as the top layer and the particle sim as the lower layer. I didn't alter any defaults except the scale of the house which I increased to 243% in scale and in the movement properties of the particle sim I set life to 2.0s.

    Are you using any deflectors?

    You may be asked to upload the project file if someone can't figure it out just from the picture you provided.

  • StormyKnight  - Sorry for my late reply, but thanks for taking the time to do a test!  That is not the same procedure I've been using.  The 3d model I'm using has material properties for the glass, so I expected that by bringing the opacity down to 20% I would see the particle simulator inside, just like I see all the other 3d models I have placed in there.  I may have to resort to the technique you describe, but there are a lot of windows and it would be quite tedious, when as far as I can tell the way I'm doing it should just work.  I have tried deflectors with no luck.  I even tried exporting the glass and the house as separate objects from 3ds Max and if I'm looking at just the house without windows the particles are where they should be.  Same for just the glass, I can see the particles through the glass and in front of the glass on what would be the back wall, but when both layers are visible in the comp the particles can't be seen inside, only in front of or behind... like the model is 2d and paper thin.

    I have put in a support ticket and sent Axel the project file, but at this point all he's said is it's probably a problem with the model but he hasn't determined what the problem is.  Also I have found a new model that suits my purpose, but it exhibits the same behavior.

  • Triem23Triem23 Moderator

    Are you 100% certain you're in 3D Unrolled and not in 3D plane? 

    2D is the square icon, 3D plane is the skewed square and 3D Unrolled is a cube. The behavior you're describing (paper-thin house) sounds like you're in a 3D plane mode. 

  • Triem23 Oooo look at you with your spiffy moderator tag :)  Well deserved I'd say, as I'm sure would many others.

    Oh yes, 100% certain.  I agree, it is behaving like it is in 3d plane mode or 2d mode.  Investigating this problem and flipping around through the modes has made me acutely aware of the differences between the modes.  I realize I need that unified 3d space that only 3d unrolled can (usually) achieve but it's just not working.

  • edited August 2016

    @TTSProd - Please keep us posted on any developments. I'm curious as to what exactly is transpiring. I apologize for my late reply too. I didn't forget- just got a project to finish within a couple weeks and I've been concentrating on that. Took a break, came here, slapped hand to forehead and realized I forgot to check back sooner. DOH!!!!!

  • StormyKnightAxelWilkinson in the support ticket and this is what he wrote back...

    "I have continued investigating this issue, and trying different models, and it does appear that there is a bug in HitFilm with regard to the way 3D unrolled particles are rendered through transparent models. So unfortunately, the scene isn't going to render the way we would like in the current version of the software. I realize this isn't the best news, and we will continue to look at what can be done to improve this in future development."

    And so begins the hunt for a work around...

     

  • I think I have the exact same issue, six months later.

    I am trying to render a car that has been set on fire on the inside, but the only flames that are visible from outside the car are those that cut through the windows and other boundaries of the model (I haven't set up all the deflectors yet). No flames can be seen through the windows.

    This is with the 2017 version.

  • I don't have the 2017 version yet, but I have been told there is a new depth map feature that is supposed to help achieve just what you're looking for.  I did give it a try with HFP2017 in trial mode and I could not get it to work but I could be doing something wrong.  Hopefully someone will chime in with more details about this new feature.

Sign in to comment

Leave a Comment