I made a png with a transparent background, but it in hitfilm it has a black background...


Im creating a number of videos following the same design.  I have completed 3, and am working on the 4th.

The first three, I was able to add my transparent images and they appeared... transparent. 

In this video, when I add a transparent image, they appear with a black background.  I even added images from the previous 3 movies, and they all appeared black in this movie.

Is there a setting that I am missing?  All of the other movies required no keying, nothing.  Just the transparent image.  But this one is screwing me up.  What on earth can the issue be?


  • Triem23Triem23 Moderator

    Right-click the ones coming in with the black bg and select properties. From there look for a setting for Alpha and make sure it's set to premultiplied. 

    You're using the exact same files imported for the first three movies? 

  • Where should I right-click the image?  Wherever I click I don't see alpha listed in its properties.

    Yes, I have tried the other images that were successfully imported into my other movies, and they too render in the movie, and the movies preview with a black background

  • If you go to the main media that you imported and then right click / properties you should see a Aspect ratio box and a Alpha box

  • edited April 2017

    Hi Guys,

    I have the same problem here. I loaded this image to my project:

    glasses link

     but when i import it the background gets black


    there's aspect ratio but no alpha option...

    i tried a couple of other .png but all come up this way. What seems to be the case ?

  • Triem23Triem23 Moderator

    To clarify, have you put the PNG files over any other layers? You might have checkerboard off?

  • wow, that's a fast reply.

    yep, checkerboard off, it comes out as a black rectangle on the viewer:

    ckecherboard off

  • Hi Guys,

    it appears that the image (images!) were faulty. I received a corrected one via PW.

    Unfortunately don't know how to deal with it in the future, is it possible to correct it with GIMP / paint.NET or any other free software... and the main question - how to do it ? :)

    Thank you!

  • Sorry dont know all technical words in English, i am german.

    I used Affinity Photo (Photoshop or something may also work).
    Affinity Photo is for Mac and PC, think there are Test-Versions available.
    Opened the PNG and exported new PNG.
    Not as "hole document", export "selection without Background".
    Thats all

  • edited May 2017

    Hi guys,

    Here my method to solve this: I put the png file in PaintNet, I saved in JPG file and then I remove the background, save again in png, and works :).

    Hope this help you!

  • You need to save your PNG as 32-bit.

    24-bit png images get a black background.

    You can do this with Paint.net

  • edited March 4

    i have the same problem with CIELKE....why the black glasses we can only see the white part..please help me....Thank you in advance


    as it goes for the particular image you can get it here. It's the same picture but saved "without background" - thanks to colamanBS :)

    if you need to convert another image try just opening it in some software  like: Photoshop/GIMP/Affinity/PaintNet and exporting again as 32-bit png.



Sign in to comment