Activation of Hitfilm 4 express not possible

I have hitfilm 3 and starter pack and Premium formats activated.

After downloading Hitfilm 4 express and installation the program asked for an activation code. Where i can get it? 

Comments

  • HitFilm 3 Express and HitFilm 4 Express are separate programs, with separate serial codes. You can register for HitFilm 4 Express and get a free serial code here: http://hitfilm.com/express/heads-up

  • Problem solved
    Thanks for the comments. In the meantime a code was generated and can be seen in my account

  • edited May 2016

    I got the code from the website but then as soon as I went to enter it I was just asked me to login so I didn't need it after all.

  • @PhilNolan that's by design. We avoid asking people to type in a serial code wherever possible, because they're really long and tedious to type in. So, if you've already got an account and already got the software registered to it, we can just use your login details instead :)

  • I have problem with Edge, IE, Firefox... i try to register program and..
    "It looks like you're using an adblocker, and it's preventing us from showing you social share buttons" I dont use any extension for Edge. How can i register program? Please help.

  • @nukleon so the social share buttons don't appear underneath that message?

  • Yep, that's the same problem I have, I tried everything from whitelisting the site, disabling the Adblocker Plus, refreshing and downloading a different browser, nothing works, it's keeps whining about the same issue and as an IT guy for many years, it's not like I'm an idiot when it comes to computers. Fix your flaw please.

  • CNKCNK
    edited June 2016

    @Redbox - Download Google Chrome and you'll see that it works. Some browsers have got built in ad-blockers, which defaults to ON.

  • edited June 2016

    Firefox does not by default block ads and neither does Chrome or Opera, you're making things up.

  • I figured out what the problem is. The page will always say "It looks like you're using an adblocker, and it's preventing us from showing you social share buttons", but it turns out the share buttons are just visible and working just fine, because like I said... none of the browsers isn't blocking anything, but you refused to listen.

  • DanielGWoodDanielGWood Staff
    edited June 2016

     @Redbox you're quite right, the message does show regardless at the moment, I'll look into that.

    It used to function as designed, but a few weeks back Adblock changed their approach slightly, and started hiding the message as well as the buttons. So in an effort to keep up, we changed our approach, and it looks like we also introduced a bug, sorry!

  • The issue should now be resolved.

  • why i can't get my serial code number 
    all i can get is 

    You have not registered any software yet.
    while i already work on the software
  • @haiha1 I'm with the same problem, i know the motive, but i don't know the solution

  • @WennZ You cannot get a new serial code for HitFilm 4 Express if you haven't got one already. You can get HitFilm Express 2017 for free by following these steps though:

    https://youtu.be/MCKI3S3E3qo

    Let us know if you need any further help

  • edited June 20

    It's the problem. my vídeo card don't suport the HFE2017, but it run without problems the HF4E. so, i use this, but without the serial code i can't export mt projects.

    In the HFE2017 i can't export my projects too. cause happening an

    error(show error) amongst others due my vídeo card


    Translated by: Translate google PT-BR

  • @WennZ we fixed an issue in the latest update of HitFilm 2017 that was causing this error message, could you make sure that you are running the latest version (5.0.6614.39737) please?

    What GPU have you got? If your card isn't supported for HitFilm 2017 then it isn't for HitFilm 4 either as the minimum requirements haven't changed.

  • @Wennz ;

    Just to back up Cedric's comment, we've rarely increased miniumum requirements in HitFilm and continue to support GPUs from as far back as 2008. HF4 might initially appear to work with unsupported hardware but you will inevitably run into problems when you try to use the more advanced features.

    However, the error in your screen shot may indicate that your system has two GPUs and that HitFilm is using the wrong one for export. Please ensure you have the latest patch (Update 6) which addressed this issue

  • @CedricBonnier The version of my Hitfilm is the 5.0.6614.39737. My "vídeo card" is Intel(R) HD Graphics 4000

  • @Danny77uk hmm, i will see that, thanks

  • @WennZ The intel HD 4000 should work and is supported in both HF4 and HF 2017. Could you contact support and send your project across so that we can test it here?

  • I  need help. On the 4th of August I installed Hit Film express 2017 and everything was fine. I had the serial code and my account was activated but when it came to exporting it always come with error therefore i couldn't export to you tube (even though there isn't an option to add your you tube account). So i uninstalled hit film express 2017 and replaced it with hit film 4 express and the only problem i have is activating my account. Can you please tell me how to do this please because i did hours of searching but i'm still unsuccessful.

  • Triem23Triem23 Moderator

    @Deshy202 if you have just downloaded Hitfilm 4 Express, serial numbers are no longer issued for it. 

    For Hitfilm Express 2017, what are your system specs? CPU, GPU, OS, RAM and storage? What Antivirus are you running? Is it a Dell or Alienware? What is the specific error on Hitfilm 2017 export? 

Sign in to comment

Leave a Comment