Error massage regarding screen resolution

Hi, I have been using Hitfilm 3 for a little bit now, I went to update it to the newest version and when I did it said that my screen resolution was insufficient and that I needed a screen of 1024x768. My screen is 1920x1080. I have reinstalled it several times and the message keeps coming up. Any help is much appreciated, thanks 

Comments

  • Aladdin4dAladdin4d Moderator

    Reset your desktop scaling to 100% and it'll work. Having to do it is annoying but it will work. What you're seeing is related to the high DPI screen support added in a recent update. Unfortunately  now when you don't have a DPI screen like you and the desktop scaling is set to something other than 100% you'll see this error. 

  • Thank you, is there another way of doing it with out having to re-scale? 

  • Aladdin4dAladdin4d Moderator

    Not that I know of but I do know the devs are aware of the issue

  • Application scaling is a bummer, but it's basically a workaround for crappy software handling high resolution screens poorly. Like web browsers and text editors.

  • edited December 2016

    HitFilm 3 did not support desktop scaling at all so the software would display at 100% scaling no matter what. HitFilm 4 has been fixed so that it will respect the scaling level you have chosen, and will adjust the interface based on your scaling setting. Increasing the scaling effectively reduces the resolution of your display, so if your scaling is set too high, there won't be enough room left for the HitFilm interface to fit.

  • That reminds me, is there a way to adjust font sizes? Or track height? I've been editing an event in HitFilm, and hoping to be able to make tracks taller to make editing audio curves and such easier.

    That said, I have it running on a laptop with a 4K screen connected to a 4K monitor and it's working nicely. It makes Premiere feel pretty klunky.

  • @WhiteCranePhoto you can resize tracks by using this arrow button on the far right:

    Resize tracks

    There isn't a way to resize fonts in the ui but since Pro 2017 you can disable HighDPI to render the interface at native resolution (ie tiny).

  • CedricBonnier     Thanks for the track resizing tip! That's very useful.

    Just to try it and see which one is easier to use, where is the HighDPI setting? I seem to be missing it, though it could be because I'm still editing at 1am. :)

     

  • HighDPI support is found in the Options screen.

  • edited January 4

    BannerCole, please edit the title. If we could have had a massage a every Microsoft error, the entire world would be stuck with win3.0 for ever man ^^

    And I agree scaling is a temporary solution. If you really need to enlarge things on your desktop, find a bigger display or just use your TV. their is no shame if you have bad eyes, but scaling is not the answer.

  • If you put a manifest file in the program it should scale.  http://www.danantonielli.com/adobe-app-scaling-on-high-dpi-displays-fix/  Just use the link and follow the directions just name the manifest file to whatever app that needs it. It worked for me anyway with a desktop scaling of 150% on an extended 1080p multi display setup.

Sign in to comment

Leave a Comment